Post install fail

After install (nice process very “pro”) when I launch the platform it tries to compile (to render the scene no to “run project”) however it fails with…

package com.jmex.model.XMLparser.Converters does not exist

does the installer not provide this?

I’m using ubuntu 64bit with working java (and plugin - jmonkey webstart works)

nvida graphics

Uhm, very strange error, why are jme2 libraries referenced? Do you try to compile jme2 examples or something here?



no idea but its the code in the default code the sdk starts up with that imports com.jmex.model.XMLparser.Converters

So, you created a BasicGame project or what? When starting the jMP for the first time there is no projects or code. I think Something is badly wrong here. Did you have NetBeans installed before and were working with jme2 projects?



I have in the past installed jme and also netBeans in the past and since uninstalled both

on a fresh install of mint rolling - I saw the same behaviour but the whole thing just froze at the 14% creating scene… (no previous installs here)

I’ve been having problems with this forum, some views not showing posts I’ve received notifications for, is there any way to get a flat traditional BB type view?

Do you have a folder /[user home]/.jmonkeyplatform ? If not, then the settings of NetBeans and jMP got mixed up somehow, I already heard of such a thing on linux.

I can believe I did in macbuntu but not on the freshly installed Mint rolling on another partition, (everything installed independently…)

On by main install the whole thing didn’t freeze and I could change the code shut the ide down and restart it…

On my fresh install Netbeans behaved in its normal loathsome manner and just choked, so this is probably a complete show stopper

I’d recommend a template that’s used immediately after a new install to avoid any previous cruft interfering with a new install…


  • test
  • @author normenhansen


    just noticed this in the code, so this is no old code of mine…

As said, a new install of jMP does not contain any opened projects unless something goes wrong. What do you mean by “template being used immediately after install”? About the code: Where is that code from? What project did you open? What projects were opened already? Whats the name of the project containing that code? Is there really an import for com.jmex… inside that code?

The code appeared first time I ran the ide in both installations it was called Main not only is there an import but other code fails to compile because of the missing import

I was recommending that you DO include a template for exactly this reason.

I have no clue where this code has come from its not mine…

What is the name of the already opened project? There is a template, just create a new project and select it, its all written in the manual (F1).

You just said in several posts there is no default project and now you say there is a template - which is it?

Just rebooted to look in the fresh install, the whole thing is frozen solid so I can only see the project name which is myTest1 which I remember entering for a new project.

so there is a template and it is using out of date code…

I said that when jMP opens for the first time that there is no project opened and I just told you, its all written in the manual. Just press the new project button…

Edit: jMP never used any jME2 code ever. I dont know why you ever got that error message, is it still appearing after all?

I can’t reproduce the problem with ubuntu, however in mint its still hanging at 14% when building the scene view

I deleted the existing project completely and made a new one with the same result

I compiled the project externally with ant and it complies fine checked it for any legacy code and saw none…

Absolutely no idea where the legacy code came from??

Equally puzzled why the IDE is totally locked out (thought it used a separate threads??) especially as the project compiles…

I’ll stick with gedit - coding by multiple guess was never my bag…

When the scene is hanging, you get a small warnings sign in the lower right corner. Click it and post the stack trace here.

nope no warning - whole thing is totally frozen, absolutely none responsive… I’ll look again later