Problem importing blend fies

please i need some help, im trying to import blend files to my project using the tool importer, but my models looks pixeled, may be im doing someting wrong in blender?

here is a screenshot:

if i import my modes in code calling j3o files with the AssetMaNager , then i create a material and finally i set manually the textures and colors. my models look fine.

so, i cant use the scene composer, because all my modes look pixeled, and is so hard to codify coordinates, scale and other particulary things for each model. i want to use the scene composer.

i hope somebody help me.

Did you use the “set smooth” button in blender before exporting the model?

yes, I set smooth in blender, but it still look pixeleted.

Select the blend file and set the resolution of generated images higher in the properties window, then import again. Note though that you should probably read up on game ready models, if you are creating objects with generated textures you seem to expect the models to work the same in blender and in a game engine, which they do not.

1 Like

Sorrry normen, but i dont know where i can change this resolution, i changed the resolution in the render properties of blender, I set this in the maximum (10000), then i importend this in JME, but it still look pixelated.

As I said, select the blend file (in the SDK) and set the resolution for imported images in the properties window.

hello, thank you for your answer normen. I seted the “Generated Texture PPU” in an higher value, 1024, 4096 an 204080, my model still look pixeled, What can be wrong?

Maybe you uploading a model so we can test it, we can figure out what’s going on.

shure, here is an example:
wood box

This link seems broken.
What about sketchfab? This blue small round button right bellow /.

lo siento, no conocĂ­a sketchfab, i set a strong normalmap, because with a strong normalmap the you can see the problem more clear.

here is the link.

Lol. This site doesn’t provide a download link :S Btw your model’s texture looks just fine. Make sure your graphic card drivers are up to date, and you are using the latest jme builds.

yea, my model looks fine in blender, but in jme this looks pixelated, i have my last drivers and the last jme build. here is an link of my model. If you import it, maybe you can see the problem. thank you for your help, and sorry for my bad english

It is working fine for me. See:

Isn’t you getting the same?

lol, well it’ snot fine from your screenshot, it kind of prove the OP’s point :p.
It looks like the MIN and mag filter of the texture are set to nearest.
@Kaelthas, isn’t there something that could go wrong regarding the matter in the blender loader process?

1 Like

It is difficult to say.

Honestly speaking I am surprised that you managed to view the box in JMP at all.
The model I downloaded had no faces (and currently adding a single line is not yet supported) so it simply contained no mesh.

Yeah, when I opened the model in blender, I didn’t saw any faces, but I thought they were all hiden, lol. Although, in jme all faces are shown.

1 Like

is strage, i downloaded my box, and i can see all faces of it in blender. i have blender 2.67

Hum. I’ve only tested your model in blender 2.5.

so, do you think is a problem of model settings in blender? or a problem in jme