Problem with 0.2

I’ve just tried to run your LWJGLDisplaySystem test in cvs on a machine with Win2000 & a Matrox G400 Dualhead graphics card, it compiles fine but when I run it the screen just flickers for a split second with the window. Is this mean’t to happen?



I’ve been assured by the guys over at puppygames on the lwjgl forum that the problem with matrox has been fixed in lwjgl 0.8. Just want to check this out with you before I go back to them.

Hmmm nope, it should come up with a window with a blue background.



Maybe I’m supposed to do something special for dual heads?

P.S. This is only with 0.2? Did you ever try running it before 0.2?

I have tried running it with 0.1.2 but I found out lwjgl 0.7 does not support Matrox cards at all. Only 0.8 supports matrox properly, but I’ve yet to see it. :frowning:



I haven’t installed the option in my driver set up for 2 monitors & the second port doesn’t do anything at the moment so it should really read as a normal 1 monitor card.



Perhaps it might be a good idea for me to write a small app just to display a window in lwjgl 0.8 to see if it really works before I worry about jME.

That sounds like an idea, find out where the problem lies, LWJGL or jME and go from there.

I think it’s the card & lwjgl 0.8 when I run one of the tests it says:


C:lwjgllwjgl-0.8>java -cp .
;lwjgl_test.jar;lwjgl.jar; org.lwjgl.test.opengl.Game
Setting display mode to 640 x 480 x 16 @60Hz
Created display.
Failed to create OpenGL due to java.lang.Exception: Mode not supported by hardware



I have had a go at fiddling with the display modes but nothing happens.

I think I may need to find myself another card. :?

Hmmm, that’s too bad. I do remember a topic in the other forums regarding the Matrox cards and getting Alien Flux working. Are you sure you have the latest drivers and everything?

I’ve been through all the drivers on the matrox site. Then I ran Java3D OpenGL version & it was OK, so I realised it was probably lwjgl.



I posted a query yesterday & they suggested only using 0.8 as it had the matrox fix, I onlyjust tried 0.8 today & still no joy. :frowning:



I’m off to post on the lwjgl forum now. (!)