Problem with Applying Textures to Mesh


I’m just new to using JME and I’m encountering some problems with textures in JME.

Here’s what’s happening:

I imported the mesh to JME from the Ogre files exported from Milkshape 3D using an Ogre Exporter plugin for Milkshape.

And the textures are messed up.

Here’s what it looks like in Cinema4D:

Texture’s fine.

and in Milkshape 3D:

Also fine.

Other 3D softwares doesn’t seem to have any problems applying the texture to the mesh.

I used C4D to model and UV map the mesh, exported it to FBX version 6.1, imported the FBX to Milkshape and exported it to Ogre then to JME.

I’m kinda stuck here, so, any solutions? Thanks!

Did you try flipping the texture? You can do that in the j3m editor.

Tried. No luck.

Anyway, I tried viewing the exported Ogre files with an Ogre Viewer, same messed up textures,

so the problem probably is with how the Milkshape 3D Ogre plugin exports the files -_-.

Gotta find another work around.

Anyone know any good Ogre exporter for C4D?

Edit: Found a solution. I tried using Spanki’s I/Ogre commercial C4D plugin to export from C4D to Ogre and it does the job well. It’s not free though.

1 Like