Problem with compiling of "HelloWorld" demo

Hi! I just download jMonkey Platform for jme3. I have tried to compile and run simple demo from tutorial (“HelloWorld”), but anytime I do it I receive an error like this:

[java]SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.UnsatisfiedLinkError: org.lwjgl.openal.EFX10.nalGenAuxiliaryEffectSlots(ILjava/nio/IntBuffer;I)V

at org.lwjgl.openal.EFX10.nalGenAuxiliaryEffectSlots(Native Method)

at org.lwjgl.openal.EFX10.alGenAuxiliaryEffectSlots(





at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(



I also tried to compile and run this demo program through NetBeans v6.9, but still received this error.

What does it mean and what should I do to resolve this?

You have an old version of lwjgl hanging somewhere in your classpath (probably [java home]/libs/). jME brings all lwjgl libraries and extracts the native libraries automatically, you dont have to add any lwjgl libraries yourself.

Thanks for your answer. But I don’t attach other libs to project. I create new project in jMonkeyPlatform and try to compile. And then receive an error. Also there is no other libraries in classpath, only those, that presented on default.

I meant your global java classpath in javahome/libs/ Did you use some lwjgl application before? Like jME2 or something else?

Did you use some lwjgl application before?


Well somehow theres a problem with an old version of lwjgl. Did you check in your java_home/lib directory if theres some lwjgl libraries in there?

Edit: this guy apparently had the same problem and supposedly fixed it by reinstalling jMP:

Thanks. I checked /lib directory and don’t found any lwjgl libraries. I have try to re-install jMP.