Problem with first person model collision


I am having issues with first person hands, where I am unable to get them to not collide with (or render above all) objects in the scene.

The hands are a model connected to a node, attached to the camera, and you can see the issue here:

Anybody have any help?


What are you using for collision detection? If your using triangle collision with a shape like a a capsule, then anything that goes outside of that shape is fair game for moving through other objects.

The player uses a CapsuleCollisionShape from the bullet library, and the hands themself use no collision at all (I figured adding collision to them would cause some sort of movement issues, like they would get stuck on stuff, isn’t the whole placing them above everything a render pipeline thing?)

No help? :frowning:

actually i don’t understand your issue. There are many examples of using characterControl.

For example here:

Also you can group collisions. This is very useful.

@mifth said:
Also you can group collisions. This is very useful.

Don't get what you mean, Im new to a lot of physics stuff..

Your code doesn't seem to be very useful to what I need, as i described in my original post, the problem is concerning the first person hand model (rendered in world) intersecting other models, when it should render over them, like in other first person games.

Just put the arm model in the gui node. This has been solved a few times on the forum already.

I tried that, but i couldn’t ever seem to get them to appear on screen when attaching them to the gui node, even when setting it to 0,0,0 position… is there some different positioning or something, or am i just blatantly missing something?

No light probably, I guess your model uses lighting material.

It does, i’ll have a look into that. Thank you guys :slight_smile:





As described here: