Problem with including Lemur

I’m trying to include Lemur GUI in my project, but im strugling with making it work. I’ve seen Lemur’s “getting started” tutorial where are written all steps to start using Lemur.
I have downloaded Lemur.jar, Lemur-proto.jar, Guava, slf4j and im using updated JME3 SDK. In a new BasicGame project i`ve included all files by right clicking on libraries tree and then > add JAR/Folder option.
I have added just one line in the basic code (GuiGlobals.initialize(this)) in SimpleInitApp method just as its said in getting started, and i have imported GuiGlobals by adding

import com.simsilica.lemur.GuiGlobals;

When im trying to run im getting this error:

Its been a while, but i still cant find solution on my own, so i thought maybe someone could help me a little bit.

Thanks in advance :wink:

The error indicates that you have not added the slf4j jar to your project.

It wasn’t clear from your description but just in case: you can’t just add the folder that has the jars. You have to add each of the jars. The “add folder” option is for when you have a folder full of class files, not jars.

Well, i added all jars i could find in slf4j and error with logger is gone, but its still not working because of this:

Im not even writing this for android, im confused.

You shouldn’t add all of the sl4j jars. You only really need one of them unless you want logging turned on. At a minimum, you just need the sl4j API jar. If you want logging on then you need one of the other implementation jars. Probably the simplest to setup is just to use the one for jdk logging. The jar might look like: slf4j-jdk14-1.7.13.jar

I personally prefer log4j but you’d also need the log4j jars and JME is using Java’s built-in logging internally anyway.

Alright, i guess i have no more problems with sl4j and guava but im still geting errors:

It looks like its an error related with JME3-core…

What version of JME are you using?

I think the old version release on google code still worked with JME 3.0 but some of the docs on github may no longer apply.

You are right, i was using jme verision 3, donwloaded 3.1 and its working fine.
Thanks for help! :wink:

1 Like

Cool. Post back if you have any other troubles.