Problem with Installation


I have tried to install the JME 2.0 and I was able to compile it successfully. But when I startet the jmetest.jar I got some errors. I already set the environment variables to the jar Files, but it didn t work. This is the console output:

C:jmetarget>java -jar jmetest.jar

15.08.2009 11:46:38 jmetest.TestChooser start

INFO: Composing Test list…

Exception in thread "main" java.lang.NoClassDefFoundError: org/lwjgl/Sys

        at jmetest.TestChooser.start(

        at jmetest.TestChooser.main(

Caused by: java.lang.ClassNotFoundException: org.lwjgl.Sys

        at$ Source)

        at Method)

        at Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at java.lang.ClassLoader.loadClassInternal(Unknown Source)

        … 2 more

Has anybody an idea what I did wrong? The CLASSPATH already includes the lwjgl.jar file so I don t know why it doesn t work.

Thanks a lot


Has nobody an idea what's going wrong?

Can you show what is your current CLASSPATH? The error says that the lwjgl.jar is not in your CLASSPATH.


I had a similar problem using Eclipse IDE, and having followed the tutorial available in the wiki section. I changed for NetBean IDE, followed the tutorial for Netbean and now everything goes just fine!

I dont know if I m of any help here, jME is very new to me (and so is Java in general  :D)

This looks as if your native libraries for lwjgl aren’t set… I’m not sure how to do this using java through the command line TBH, as I set thing up on a per-project basis using my IDE

Setting up Eclipse or Netbeans When You Already Have The jME Jar’s

As for your original post, to run the TestChooser class, issue the command like this:

run jmetest.TestChooser


OK thanks for your answers. I didn't want to change my IDE but know I'll try it with Netbeans because I already tried it for hours now :smiley: . I'll tell you if it works.


Ok now it works.