Problem with Oculus Rift lib on Ubuntu


since you guys managed to get everything running on 0.4.4 i wanted to try out if i could get my stuff running on ubuntu. So i updated the correct jars but i encounterd the following problem:

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
java.lang.UnsatisfiedLinkError: org.lwjgl.opengl.LinuxDisplay.nSetClassHint(JJJJ)V
	at org.lwjgl.opengl.LinuxDisplay.nSetClassHint(Native Method)
	at org.lwjgl.opengl.LinuxDisplay.setClassHint(
	at org.lwjgl.opengl.LinuxDisplay.createWindow(
	at org.lwjgl.opengl.Display.createWindow(
	at org.lwjgl.opengl.Display.create(
	at org.lwjgl.opengl.Display.create(
	at com.jme3.system.lwjgl.LwjglDisplay.createContext(
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(

Exception: java.lang.NullPointerException thrown from the UncaughtExceptionHandler in thread "LWJGL Renderer Thread"

The error is with the lwjbl jars, however I am using the libraries from phr00t as he said before:

@phr00t said: I did just submit an update to my github repository that fixes a capability problem that caused crashes on Rift starts:

I wouldn’t use the main jME3 branch with this Oculus Rift library, it might not work. Using my library is pretty easy – just use the libraries in dist/ and lib/ above instead of the ones provided by jME3.

So I wondering if he or somebody else has an idea? I did notice there is this thread but that doesn’t really help me.

Hrm… are you using the lwjgl libraries from this directory?

yes i am :slight_smile:

i tried with both of them (first with the ones in the main directory and afterwars with the others) but they both give the same error

btw to be clear, this problem only occurs on ubuntu. I did exactly the same thing on windows to go to 0.4.4 and everything works just fine.