Problem with opening sceneViewer

hello,I’m new to JME. Here’s my problem when i open the sdk there’s an error saying ‘error opening opengl window’. Also,the status bar below showing ‘Opening SceneViewer 14%’. and never progress.

I can run demos correctly.but the sceneExplorer seems to be not working. Can anyone help me >

Try going to the application settings, then under “OpenGL” select “use heavyweight canvas”.

:?I selected" use heavyweight canvas", then the sdk just can’t start again, I’m running it on windows 7 in vmware

@shoulianyu said:
in vmware

Oh, just forget about that, the OpenGL support of VMWare is by far not enough to properly support the IDE, maybe you get somewhere enabling OpenGL1 in the same window but it'll be less than pleasant. Why not run the IDE in the host OS? :?

I also have installed JME on my host windows xp . The problem with xp is when the jme starts up there a lot of warnings for example , Error in scene : the Drawable has no context available, Error in scene NullPointer, Error in scene could not create Pbuffer Error in scene Framebuffer doesn’t have any renderbuffers attached. However some demos can run correctly

Install the latest graphics drivers from the card manufacturer.

I guess the problem might be with my graphic card or its driver, I have tried changing the driver. but Everytime a new problem emerges. My graphic card is intel mobile® 965. are there any drivers suitable? Or maybe I should try install a windows 7 on my computer?

Did you try the OpenGL1 option? I doubt this card properly supports OpenGL 2.0 at all.

Not yet, I’ll try

Lots of thanks, I selected the “use heavyweight canvas” and it worked in xp.:):smiley: