Problem with running build.xml

okay so i have been busy and haven't been doing alot of developing with jme lately and now that jme2 came out and it is summer time i have more time to delve into it…

i was at the building jar stage for the entire distro when this occurred during build…

i did all the steps necessary before hand to make sure i had everything correct…i have no errors in the code when i go to the problem tab…i just have a couple warnings about some class generic crap…

ohhh i forgot to say this is for eclipse Galileo  i believe it to be a nightly stable release i downloaded this year…

i was wondering what could be the error i believe it has to do with the javac.exe but not sure if it is an error on my part in not doing something correct…

Buildfile: C:Usersadramalechworkspacejmonkeyenginebuild.xml
     [echo] jmeKeyStore
    [javac] Compiling 794 source files to C:Usersadramalechworkspacejmonkeyenginebuild

C:Usersadramalechworkspacejmonkeyenginebuild.xml:71: Error running javac.exe compiler

Total time: 1 second

If you are running Galileo, I think it needs JDK 6 to run and compile.


i believe i am running jre/jdk 1.6.12 or 1.6.15 or something like that…but i might as well check it and make sure just in case…

okay so i tried to redo everything i did except rename the svn repo from jmonkeyengine to jme2 and then i went through the normal stuff to get to the step about building all the .jar files…

but no go on it…is there like a troubleshooting page that shows what i should look for in what is wrong…

one more thing is that there are no errors just warnings in the problem tab of eclipse…

furthermore,  the warnings are class raw type something about parametrize <T>

here is what i got this time:

Buildfile: C:Usersadramalechworkspacejme2build.xml
     [echo] jmeKeyStore
    [mkdir] Created dir: C:Usersadramalechworkspacejme2build
    [mkdir] Created dir: C:Usersadramalechworkspacejme2datadoc
     [copy] Copying 1 file to C:Usersadramalechworkspacejme2
     [copy] Copying 40 files to C:Usersadramalechworkspacejme2build
     [copy] Copied 117 empty directories to 87 empty directories under C:Usersadramalechworkspacejme2build
    [javac] Compiling 794 source files to C:Usersadramalechworkspacejme2build

C:Usersadramalechworkspacejme2build.xml:71: Error running javac.exe compiler

Total time: 2 seconds

"Error running javac.exe"

seems it can't find yor javac.exe :slight_smile:

Do you have a jdk installed and its /bin folder in your PATH environment?

okay i right clicked on the project and went to properties and then to java compiler it is running on 1.6…

i was wondering how to see if the PATH is correct in eclipse…where would it be located???

i meant the windows 'Path' Environment variable.

okay i still get the error on line 71 on build.xml about that javac.exe i just added the jdk to the environment variable Path…

maybe i did something wrong…idk i am doing this in vista i might just try and do it in my sun's vb with ubuntu 9.04 that i have installed…with a different svn

okay here is the line when i go to build error and it takes me to build.xml at line 71 and this is what is highlighted

 memoryMaximumSize="${javac.maxmem}" debug="${javac.debug}"/>

maybe something wrong with memory setting??? or debug settings????

i also set jre to workspace jre....which is 1.6

i just stumbled over the same problem when setting up eclipse new.

You need to point Eclipse to a JDK not JRE.

Window -> Preferences -> Java -> Installed JREs -> select a JDK (add one if necessary)

okay so i got that far but when i go to add one i don't know the arguments correctly to get the ide to point to the jdk…

Browse to the directory where you installed the JDK. Usually this is C:jdk1.6.0_13.

Eclipse will recognize the JDK.