Problems Building the Project

Hi there,

I’m new to jMonkey Engine but it was a pleasure to toy around with it so far. So thanks for a great tool, right from the start!

My Problem is building the Project, to try running it on other systems (maybe).

I am following the tutorials, implementing all the Stuff in my own project right away, using the Resources from the jme3testdata package. So nothing special is going on so far.

I did a clean build, packed up the result in “dist” and sent it to a freind of mine. Guess what: it doesn’t work.

His rig shows the jMonkey settings dialog and once hitting “Ok”, the Dialog disappears and nothing happens.

Running the same binary on my PC causes no problems. I took the same stuff I sent away to a path, unrelated to the Workspace and still no Problems for me.

I hope I miss a major step in building the source or something. But I didn’t finde anything on that yet…

Don’t want to involve the Guy in collecting debugging information if possible :slight_smile:

Can you help me?



Idk about it, but it might work if he tries to run it using cmd.exe

Then MAYBE, not saying it will, the error message will appear in the cmd after the program has exit…

Dunno, just a thought…

Yeah, run from command line to see any error output, cant help much with “doesnt work”. One guess might be you use OgreXML files directly, they are not included in the release version of your application as you are expected to use j3o files instead. You can change that in the project settings.

1 Like

Thanks for the reply.

That would be, explaining the guy, how to run a command-line and what to do in it… I hoped for someone to open my mind to obvious stuff like “SURE, you need to build it, using the other Button! That way it is only running with JDK installed, moron!” or alike.


Oh, it was working by double-clicking on your computer? Then forget the OgreXML thing. Did you send him the jar or exe and the lib folder? The lib folder contains all libraries and data, its important to send that as well.

Running from command line would involve opening a command line then typing “cd C:/path/to/game” and “java -jar MyGame.jar”. Does the computer of your friend support OpenGL 2.0?

Told him the Command-Line magic a minute ago. Result:

‘java’ is not recognized as an internal or external command,

operable program or batch file.

Probably doestn’t mean there ist no JRE on his System, as the settings dialog works… and he’s playing Minecraft right now…

What next? :smiley:

Thanks so far!


Hm, when the java command is not recognized his java version is probably not properly installed, maybe reinstalling Java does the trick. I dont know Minecraft, maybe it brings its own JVM with it?

Sorry, sure I send him the entire Folder. As I said, i copyed the same stuff to an Workspace-unrelated folder on my System and it works.

It is not, that I am new to Java. This is just my first step from two into three dimensions.

His System should have OpenGL 2.0 Support. He bought some nasty ATI graphics adapter > 400 bucks a month ago. OpenGL 2.1 support is included in ATI driver packages since 2007, so the conclusion is solid enough I guess.

I see this leads to nothing without his command-line output. I will try to get it sometime. Thanks!

Yes, I will recommend that to him. Unfortunately my “game” is no reason for him to take that effort… yet. :wink:


Minecraft is a highly decorated Java indie game. Over 750.000 sold copies (10 EUR each) while in alpha(!). Now I’ts beta (15 EUR, including seasonal discount)… facts that make me get to work again :smiley:

I know about Minecraft, I just didnt install it so I dont know if it brings its own JVM

NORMEN. You are GOD! I had same problem.

Just in to project/properties/build/asset > assets jar excludes > set " * ". > asset jar will include all your filles from asset. *My assed didn’t include some models.

Expect my game soon :slight_smile: