Problems exporting MD2 files

I have a friend who’s making models for my game. I want to use MD2 as the model format since it seems to be very well supported with jME, but we’re having problems. He’s tried two things to export MD2 models:

Milkshape: When using Milkshape it requires him to have a .qc file (I’m pretty sure jME doesn’t care about it), and when he loads it in the game the textures are not mapped correctly (and when I try to load it using the same program, I don’t see anything at all, but jME says there are polygons in every direction I point the camera!).

Blender: Using this exporter, he tried to export the model, but it created a 15kb file, which obviously did not load in the ModelLoader.

I’m using the Md2ToJme class to export these models to .jme (with no properties set). The model can be found here.

What’s going on? What should he be using to export these models?

Try using one of the converters available on the third party apps page.

I’ve been saving my files as milkshape files and then I convert them using Per’s converter which has worked out fine so far.

Hmmm… funny you mention that, my converter happens to be “Greg’s Converter” :slight_smile:

Maybe mine’s bad? I’ll get back to you in a sec on this.

Edit: Nope doesn’t work, our code is practically identical for that part (except for the part to convert obj’s, his ignores mtllib files… Per… shame shame :P)

Well for my model it was a 3ds model that I imported into Milkshape and then saved as a milkshape model.

When you say the textures are not mapped correctly do you mean they don’t show up at all or they show up and are all messed up?

all messed up. Temporarily I guess we can use Milkshape, but it seems like MD2 handles more advanced animation (from looking at Dr. Freak)? Actually, he changed it a bit, and now it doesn’t even show the model at all (but still renders the invisible polygons according to fpsNode; same thing I’m getting).

Anybody using the latest version of Md2ToJme and can say if they’re experiencing this or not?

E-mail your md2 model to either Cep or myself. And we’ll try to figure out what the problem is.

E-mail your md2 model to either Cep or myself. And we'll try to figure out what the problem is.

Gotta love that service :D
"mojomonk" wrote:
E-mail your md2 model to either Cep or myself. And we'll try to figure out what the problem is.
Thanks! I sent you the email.

Definately, see what you are talking about (or don’t see as the case may be).

I then loaded the model (imported) into Milkshape 3D and it too had problems, couldn’t display anything.

What did your friend use to make it, and what application can I load it with to play with the settings?

He used Milkshape to export it (Wings3D and 3DS Max to make it). What should he be using to make it?

Edit: does Milkshape export MD2 files fine for you?

I don’t really know, I’m not a modeler and don’t have much experience with the tools. My process was, 1, try to load in jME. I saw the issue you referred to. So I tried to load it in Milkshape to see if anything was obvious and Milkshape couldn’t view it either. I used Milkshapes import MD2 feature.

After talking with your modeler, I suspect it is a problem with the tool. Exporting to MD2 appears to be doing something very add (requiring the addition of joints to MD2 is suspect to me). He said he too is unable to export it to MD2 then import it back from MD2. This tells me that the exported MD2 is not built properly.

Hmmm… yes, so I’m wondering, for those people who do use MD2 on these forums, how do you guys export your models?