Problems importing a library in jmep

Hi, I have been working on a game, and I am trying to import a library into the Netbeans platform for jme3. The files are stored in the zip like this:



TJHJava-libnoiseforjava-3399aa.zip/

TJHJava-libnoiseforjava-3399aa/

src/

libnoiseforjava/

exception/

(java code)

model/

(java code)

module/

(java code)

util/

(java code)

(more java code)



I tried to add an import in Netbeans, and it said that there was no library under the import. Here is my import code:



[java]import libnoiseforjava.module.;

import libnoiseforjava.util.
;

import libnoiseforjava.exception.*;[/java]



Is there an error with the zip file or is it not compatible? I added the library under these steps:



I clicked on tools/library manager

I made a new library called “libnoiseforjava”

I pointed it to the .zip file I explained



Thanks,

dangerdoc

oO What? If you just want to add a jar to your game project, go to the project settings->Libraries->Add jar

I tried selecting the .zip the way you told me, and it had the same error. I used the same imports, and it had the same error. I right-clickes the libraries tab under projects, and pressed add jar/folder. it added the .zip, but it had the same results. Am I doing something wrong?



thanks,

dangerdoc

@dangerdoc said:Am I doing something wrong?


Yes. You've downloaded an archive of the source files. You're really looking for a pre-built jar.

That was the only download file there was. How can I make one?



Thanks,

dangerdoc

:brainsout:

Is there a build file?



If there’a a build.xml you can just navigate there and type “ant” and it should build. javac also works, though you’d need to wrap the JAR yourself.

Is this what you’re trying to use? GitHub - TJHJava/libnoiseforjava: Java port of the C++ library libnoise.



You can just create a NetBeans Module/Project and drop the sources in there, no?

1 Like

…or put the sources in your game project.

1 Like

Yeah, all these are solutions I woudn’t have thought about… I guess I have to learn how to think outside the box also.



Thank you,

dangerdoc

No, just think like a java developer ^^

2 Likes

:smiley:

I have encountered yet ANOTHER problem. I don’t think that either of your solutions will work… The classes have imports to other classes that do not even exist. I would just add them into the project, but almost every one of the classes has an input to a non-existing class. If this API is broken, do you know how to fix it or where another API for 3-D generation is?



thanks,

dangerdoc

The project you’re trying to use probably has dependencies on another library, or libraries. Just look for libraries that include those classes and add them to your classpath.

:facepalm: :brainsout: