Problems with Code Tutorial and missing classes

I've downloaded the jme library zip (6.60 MB) at august 2nd.

I also downloaded the jME SDK Documentation

And the PDF file containing the 13 code tutorials

Most of them worked fine, but there were some problems.

The SDK doc fits to the code in the tutorial.

But the actual jme classes in the .jar files do not some times.

I don't know what I downloaded, exactely. Maybe that was just a "at-work" version?

There's nowhere a version number to be found in the .zip or the .jar files containing the jme classes

If this WAS the (to that time) up-to-date version, then the SDK doc doesn't fit any longer … :confused:

I hope that someone here can help me and tell me how to fix the missing stuff and/or where to get a "proper" version of jme.

Or at least explain where that little chaos between the Tutorial and the library i downloaded comes from…

0.) minor things

which i managed to fix by myself

  • Structure

    Some classes are under a "jmex" directory instead of the "jme" directory and are sometimes also moved in the directory structure:

    Tutorial-PDF : com.jme.scene.model.XXXXX

    jme-model.jar: com.jmex.model.XXXXX

  • Redundant methodes

    Texture t = TextureManager.loadTexture(monkeyLoc, Texture.MM_LINEAR, Texture.FM_LINEAR, true);

    It appears there no longer is a methode loadtexture(URL, int, int, boolean).

    So i used one that exists:

    Texture t = TextureManager.loadTexture(monkeyLoc, Texture.MM_LINEAR, Texture.FM_LINEAR, 1.0f, true);

    1.) Odd Runtime Error

    in HelloSimpleGame

    All found, all compiled, all fine. jme starter appears. Then:

    Runtime Error: “NullPointerException at Line …”

    -> fpsNode.updateGeometricState(0.0f, true);

    solved :slight_smile:

    2.) Things that don’t exist

    …any longer appearently and couldn’t be found anywhere else in the various jme-[…].jar files

    in HelloIntersection

    not existent:




    in HelloLOD

    not existent:


    CameraCurveController solved

hm okay, thx fpr the answer.

I did download the "nightly build" back then. But as I noticed now, the last update of the "nightly build" was AFTER i downloaded the

So i download it once again.

But still the mentioned required classes from the code tutorial "HelloIntersection" and "HelloLOD" aren't there!

And the SDK doc does not fit to the jME library in these points!

Can anyone tell me where the answer lies?  :? :?

Really, I seem to have had better luck checking out the source from CVS into an Eclipse project and then just having anything I'm developing reference that.  These guys seem to be pretty good about only checking in when things are NOT broken. :o

Anyway, if you can't or don't want to do CVS I would recommend downloading the nightly build as it is basically the same thing…there hasn't been a whole lot changed to jME as of late, but hopefully things will pick up again.


I don't believe this is a problem with the jME builds but a problem with yours as they work fine for me.

Verify you have all the necessary jars in your path and if it's saying it's missing things, track those down and make sure they are visible.  Sorry I can't be more help, but I'm trying to debug a problem that I'm not having. :slight_smile:


The user's guide is outdated, the maintainer has not been around for awhile. So, there are certainly things that are different.

When you refer to these problems, are you talking about code in the User's Guide (which is not going to be right) or code in jmetest.TutorialGuide.* (which is fine and working)?

hi mojomonk!

Some problems where in deed on my side.

The runtime error and the missing class "CameraCurveController" which actually is "CurveController". The "Camera" was part of a comment that got in the wrong line.

Still, there are some problems that definitely lie on jme side.

You say the tutorial is outdated. Okay that's an explanation for why the classes can't be found.


Then the SDK doc is outdated, too. As it fits perfectly to the code used in the tutorial.

To be more specific:

The (old) code tutotial as well as the SDK doc mention following classes that don't exist any more:




I saw that in the jme-sound.jar, the sub directory now is "jmex" instead of "jme". But still nowhere in any of the sub directories can one of these classes be found.

Okay maybe the code samples in jmetest.TutorialGuide are updated. But they are contained only as .class, not as .java. So I can't look at the code.

Where do i get them without downloading the whole jME Code via CVS ?

And much more important:

If the SDK doc is outdated,too, where do i get one that is up to date?

It would make learning jME much easier, if i had a proper documentation :frowning:

I don't want to download the whole jME code via CVS.

I don't want to hack around in the engine code itself. I just want to use it.

All I want is the compiled jME library (which i already have).

An up-to-date tutorial for getting into it.

And an up-to-date documentation.

The SDK doc is not out dated, it references the current release (0.8).

Just start making use of cvs repo, it'd make life much easier for you. One thing we'll look into is adding a to the nightly builds, that way, javadocs will be done each night as well.

Until then:

will allow you to look at the source in CVS without downloading it.

wow cool!

that helps a lot, thx!

Immediately made a look into

All the missing sound class imports (like SoundAPIController) have been replaced by

“import com.jmex.sound.fmod.SoundSystem;”

Now i’m pretty confident that things will work.

But one note, though:

All the removed classes (i.e. SoundAPIController) can still be found in the SDK doc.

Every removed thing that is in the outdated tutorial can still be found in the current documentation (jME Documentation version 0.8)

That’s what confused me (an still does…).

Anyway. Now that I can look at the 0.8-code, it should be a lot easier.

(PS: I can’t use CVS because my PC has no internet connection, as long as i’m in my parents’ house during vacation. And my father’s PC, with which I’m online, has no Eclipse, no CVS, nothing at all. Except a browser and a bad working wireless keyboard :smiley: )

Hi do u have the latest version i am asking bcs i dont have cvs if u have could u post it here pleass tks

Latest code for the Tutorial guide classes can be viewed here: