Project assetManager doesn't exist!?

That one is very weird.



I’m trying to change the model I’m using right now, but if I try to import it using the new model importer, or by trying to convert the ogreMesh directly from the Files window->assets->…-> right-click Convert to jME3 binary, I get “Project has no AssetManager!”



Oddly enough, when I run the game, the model I’m using right now loads… I also noticed that the assets in the Projects files has disappeared. I haven’t changed anything to the assetManager, at least I don’t think so!



So, what should I look for to fix that?

Quoting normen from the other thread…

normen said:
This normally means you try to import a model into a non-jMP project. You have to select a proper jMP project to import models to.


I don't understand. I created my project, the whole thing, with jME. How can it not recognize that?

Could it be that the problem stems from my repetitive plugin error? Multiple uninstalls/reinstalls?

I dont know

Alright then.



I’ll uninstall jMP, but as usual, I’ll lose the project, local history (Waaaaa!) and whatever. So, how do you want me to import the project?



I know about the choices I have, I just want to make sure it’ll work.



EDIT: I’ll reinstall in the default directory this time. Hopefully that’ll get rid of that pesky error.

Importing didn’t work.



Redoing the whole darn thing from empty files, copying the content of each file from the backup, after having started a brand spanking new project (the mygame project), I still get the same error.



I’m on the verge of strangling something. :frowning:



I wanted to put a preview out today…



So there’s something wrong in my project I guess, but what? How can the model I’m currently using load while at the same time jMP complains about lacking an AssetManager when importing?



I need answers guys. :frowning:

Yes, in my project i can’t see the project assets too.

glaucomardano said:
Yes, in my project i can't see the project assets too.


Did you use to see it?

I don't remember at which point it disappeared, maybe you can if it was there before?

after i updated my jmp i can’t see my project asset folder, i tried to use the import model but i get this exception :

The exact same thing I have.



At least I’m not alone.

Did you change the default folder for assets somehow? Also, did you update to the latest version of the core? You can see it if theres an assets-impl.xml in your nbproject folder. If there is none, your project has not been updated properly to the latest changes in the build system.

Assets uses the default folder.

There’s no such file in nbproject (assets-impl.xml)



Is there some way to reconstruct that?



Note that I just reinstalled the whole thing, so it should be there.



Here’s the content of the nbproject:



Well that is definitely wrong. Theres no assets.properties (as before) or assets-impl.xml (like currently) in your project folder… It seems like the properties file was deleted but the project wasnt updated… Can you show me the contents of your project.xml and project.properties please? (use blockquote to post, the code tags swallow tags in the code).

With the latest nightly, the assets-impl.xml should be recreated when the project does not contain the extension.



P.S. I somehow have the feeling that windows does strange things with the user permissions, its almost like theres restrictions for jMP to write to its own folders and the projects folders…

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://www.netbeans.org/ns/project/1">
<type>org.netbeans.modules.java.j2seproject</type>
<configuration>
<data xmlns="http://www.netbeans.org/ns/j2se-project/3">
<name>BasicGame</name>
<source-roots>
<root id="src.dir"/>
</source-roots>
<test-roots/>
</data>
</configuration>
</project>

annotation.processing.enabled=true
annotation.processing.enabled.in.editor=false
annotation.processing.run.all.processors=true
application.title=MyGame
application.vendor=MyCompany
assets.compress=true
assets.excludes=**/*.mesh.xml,**/*.skeleton.xml,**/*.scene,**/*.material,**/*.meshxml,**/*.skeletonxml,**/*.obj,**/*.mtl
assets.folder.name=assets
assets.jar.name=assets.jar
build.classes.dir=${build.dir}/classes
build.classes.excludes=**/*.java,**/*.form
# This directory is removed when the project is cleaned:
build.dir=build
build.generated.dir=${build.dir}/generated
build.generated.sources.dir=${build.dir}/generated-sources
# Only compile against the classpath explicitly listed here:
build.sysclasspath=ignore
build.test.classes.dir=${build.dir}/test/classes
build.test.results.dir=${build.dir}/test/results
# Uncomment to specify the preferred debugger connection transport:
#debug.transport=dt_socket
debug.classpath=
${run.classpath}
debug.test.classpath=
${run.test.classpath}
# This directory is removed when the project is cleaned:
dist.dir=dist
dist.jar=${dist.dir}/${application.title}.jar
dist.javadoc.dir=${dist.dir}/javadoc
endorsed.classpath=
excludes=
file.reference.BasicGameTemplate-assets=assets
includes=**
jar.archive.disabled=${jnlp.enabled}
jar.compress=false
jar.index=${jnlp.enabled}
javac.classpath=
${libs.jme3.classpath}:/
${libs.jme3-libraries.classpath}:/
${file.reference.BasicGameTemplate-assets}:/
${libs.jme3-test-data.classpath}
# Space-separated list of extra javac options
javac.compilerargs=
javac.deprecation=false
javac.processorpath=
${javac.classpath}
javac.source=1.5
javac.target=1.5
javac.test.classpath=
${javac.classpath}:/
${build.classes.dir}:/
${libs.junit.classpath}:/
${libs.junit_4.classpath}
javadoc.additionalparam=
javadoc.author=false
javadoc.encoding=${source.encoding}
javadoc.noindex=false
javadoc.nonavbar=false
javadoc.notree=false
javadoc.private=false
javadoc.splitindex=true
javadoc.use=true
javadoc.version=false
javadoc.windowtitle=
jaxbwiz.endorsed.dirs="${netbeans.home}/../ide12/modules/ext/jaxb/api"
jnlp.codebase.type=local
jnlp.descriptor=application
jnlp.enabled=false
jnlp.mixed.code=defaut
jnlp.offline-allowed=false
jnlp.signed=false
main.class=mygame.test.OgreSceneTest
meta.inf.dir=${src.dir}/META-INF
manifest.file=MANIFEST.MF
platform.active=default_platform
run.classpath=
${javac.classpath}:/
${build.classes.dir}
# Space-separated list of JVM arguments used when running the project
# (you may also define separate properties like run-sys-prop.name=value instead of -Dname=value
# or test-sys-prop.name=value to set system properties for unit tests):
run.jvmargs=
run.test.classpath=
${javac.test.classpath}:/
${build.test.classes.dir}
source.encoding=UTF-8
src.dir=src

Ok, something went wrong here. The old properties file was deleted but apparently jMP could not create the new files. Try closing the project, then creating an assets.properties file in the nbproject folder with the following content:


assets.compress=true
assets.excludes=**/*.mesh.xml,**/*.skeleton.xml,**/*.scene,**/*.material,**/*.meshxml,**/*.skeletonxml,**/*.obj,**/*.mtl
assets.folder.name=assets
assets.jar.name=assets.jar


Then open the project and look for any exceptions (warning sign in the bottom right).

i already have this assets.properties file. But still doesn’t works.

Here’s the content of project.xml







And here’s project.properties:



annotation.processing.enabled=true

annotation.processing.enabled.in.editor=false

annotation.processing.run.all.processors=true

application.title=MyGame

application.vendor=MyCompany

assets.jar.name=assets.jar

assets.excludes=/*.mesh.xml,/.skeleton.xml,**/.scene,/*.material,/.meshxml,**/.skeletonxml,/*.obj,/.mtl

assets.folder.name=assets

assets.compress=true

build.classes.dir=${build.dir}/classes

build.classes.excludes=**/
.java,**/*.form

This directory is removed when the project is cleaned:

build.dir=build

build.generated.dir=${build.dir}/generated

build.generated.sources.dir=${build.dir}/generated-sources

Only compile against the classpath explicitly listed here:

build.sysclasspath=ignore

build.test.classes.dir=${build.dir}/test/classes

build.test.results.dir=${build.dir}/test/results

Uncomment to specify the preferred debugger connection transport:

#debug.transport=dt_socket

debug.classpath=

${run.classpath}

debug.test.classpath=

${run.test.classpath}

This directory is removed when the project is cleaned:

dist.dir=dist

dist.jar=${dist.dir}/${application.title}.jar

dist.javadoc.dir=${dist.dir}/javadoc

endorsed.classpath=

excludes=

includes=**

jar.compress=true

javac.classpath=

${libs.jme3.classpath}:confused:

${libs.jme3-libraries.classpath}:confused:

${libs.jme3-libraries-gui.classpath}

Space-separated list of extra javac options

javac.compilerargs=

javac.deprecation=true

javac.processorpath=

${javac.classpath}

javac.source=1.5

javac.target=1.5

javac.test.classpath=

${javac.classpath}:confused:

${build.classes.dir}:confused:

${libs.junit.classpath}:confused:

${libs.junit_4.classpath}

javadoc.additionalparam=

javadoc.author=false

javadoc.encoding=${source.encoding}

javadoc.noindex=false

javadoc.nonavbar=false

javadoc.notree=false

javadoc.private=false

javadoc.splitindex=true

javadoc.use=true

javadoc.version=false

javadoc.windowtitle=

jaxbwiz.endorsed.dirs=“${netbeans.home}/…/ide12/modules/ext/jaxb/api”

jnlp.codebase.type=local

jnlp.descriptor=application

jnlp.enabled=false

jnlp.offline-allowed=false

jnlp.signed=false

main.class=StellarConquest.Game

meta.inf.dir=${src.dir}/META-INF

manifest.file=MANIFEST.MF

platform.active=default_platform

run.classpath=

${javac.classpath}:confused:

${build.classes.dir}:confused:

${assets.folder.name}

Space-separated list of JVM arguments used when running the project

(you may also define separate properties like run-sys-prop.name=value instead of -Dname=value

or test-sys-prop.name=value to set system properties for unit tests):

run.jvmargs=

run.test.classpath=

${javac.test.classpath}:confused:

${build.test.classes.dir}

source.encoding=UTF-8

src.dir=src



========



Note that I have a backup assets.properties file that I tried. I copied it into the new directory but when I check the project’s properties, it tells me it cannot delete the file… :confused: !?



Checking the file/dir permissions didn’t show anything suspicious. Windows is now more protective of the “Program Files” area and it would have been possible that this could’ve caused the problem because of the way jMP is updated, but remember that before that last reinstall, I was on D: drive where no such protection exist. My reasoning is either there’s a really well hidden bug somewhere or it’s the updater foobaring the update with certain files on Windows.



I know it’s only stabs in the dark, but that’s all I’ve got for now.



EDIT: It seems even blockquotes eat the tags up, so I removed all tags. After 3 tries. lol

EDIT EDIT EDIT: :stuck_out_tongue: Used an image. Can’t go wrong with that.

Windows doesn’t suck. Some of its implementations are… err, not that good, I agree, but as a whole, it’s quite good. At least Win7 is.



Windows can’t be guilty of what’s going on. Look at how many new plugins and updates I installed since this afternoon. Why did only that problem cropped up? If it were a permission thing, a lot more than that would fail. I’ve been repairing PCs for the last 20 years. I have a good idea of where I’m going when pinning problems down. :slight_smile:



Anyway, I’ll check your proposition for the fix and I’ll let you know in 10 mins.

You have to replace all “<” signs with “& lt;” (without the space) to make tags show up… But from looking in your post I saw that the build extension is missing for you too. So do as I said in the post. There should be an error message when it fails to copy the file, maybe that gives us more info.



I am just wondering why you two are the only ones having those problems, did you enable any special windows user rights settings or something?? Windows sucks -.-

You had all kinds of problems already, they all would be pretty well explained with your windows disallowing the software to write to the disk… I stopped “repairing” PC’s and started working with them when I left Windows behind… :wink:

Doesn’t work either here.

When I open the project’s properties, click on Build->Assets, I get:



“Cannot delete file assets.properties in C:blablahnbproject.”



Delete? lol