Pssm shadows rendering over particles

Hi,



I’ve got a simple(?) problem in my current project. I’m using both particle effects and pssm shadows. The problem I have is that the shadows are rendered over the particle effects which looks really bad in some places. Is there any way to make particle effects render after pssm but not over all geometries?



Thanks in advance!

Using a second ViewPort should work.

Or put your particleEmitters in the translucent Bucket instead of transparent.

1 Like

I’m still actually stuck with this one. I don’t really know how to use ViewPorts. When I tried to figure it out by reading the javadoc it seemed really complicated. Could you give me some pointers on that please… Using translucent bucket won’t help as then the particles render over everything which I don’t want to happen.

@pate5 said:
Using translucent bucket won't help as then the particles render over everything which I don't want to happen.

Depth test has to be enabled on your particle emitter material.
1 Like

Doesnt a shadow option like .castandreceive or .Off work for effects after you batch them in a batch node and set its shadow to .Off?

I enabled the depth test like nehon said and it works perfectly. Thanks.

Still got some problems with this, as the particles start to render over everything if I enable postprocessor other than pssm. I just wanted the particles to render over pssm shadows but not over every geometry.

what other processor do you have?

If it’s a FilterPostProcessor, there’s one more step to take, and add a TranslucentBucketFilter to your filter list then you can switch orders of the filter to suit your rendering order.

1 Like