Random JME3 SDK crashes

Seemingly randomly the JME3 SDK simply freezes for 0-5 seconds, then the window disappears. Sometimes when I attempt to reopen it, it works. In other cases, it just won’t open. I am running on Fedora 21 x64 with Oracle Java 7 x64 and OpenJDK 8 x64. Some debugging has shown me that the SDK appears to be using Oracle Java 7 x64. What do I need to do to get a stable SDK on my Fedora installation? I’ve already tried filing bug reports for this and searching around for general NetBeans errors, but I’ve found nothing helpful about any similar issues.

it is likely grafic driver related, what hardware do you have and what driver do you use?

I have a MSI GTX 770 with the official drivers (installed via rpmfusion).

if you start it via console/pipe output to a file, is there any exception when the issues happens printed?

You can try running with another JDK and also follow the generic troubleshooting tips: http://wiki.jmonkeyengine.org/doku.php/sdk:troubleshooting

I tried it with Oracle JDK 8 x64 as @normen suggested, it works perfectly. There have been no crashes since I switched versions! Although, it may be worth looking into making it work with both Oracle JDK 7 and OpenJDK to prevent future issues – I’m sure I’m not the only one using OpenJDK.