RPG Toolset: Engine Demo

For anyone interested, I have a Java Web Start engine demo up for my RPG Toolset project, the link for the site is at the bottom of this post.  I have only been able to test this in Windows, but I believe I have the proper native libraries for it to run under Linux or Mac OS.  Let me know if you run into any issues.  I released v0.1 of the actual toolset last month, but that version uses Xith3D, and I am currently in the process of converting the toolset over to jME.  I’m definitely liking jME so far!  :smiley:


Looks pretty cool, I haven't tried out the actual editor yet, but that looks particularly well done. The engine demo ran smooth and looked clean.

Does it require any heigh end card, its not working with me here  !!. usual jme dialog for start up appears, but when click on start nothing shows ?

Forget to, java 6 beta 2

As far as I know, it shouldn't require a high-end card.  I tested it on an older PC with a GeForce Ti4200, I believe, and it seemed to run fine.  Can you enable the Java console and see what errors, if any, you are getting?

Went to control panel, checked that option, but still nothing appears !.

So when you click OK to start the demo, the console disappears along with the dialog?  What type of video card do you have?  If I get a chance this evening, I will install Java 6 beta 2 and see if I run into the same issue…

So when you click OK to start the demo, the console disappears along with the dialog?



Mobile Intel ® 915GM Express, which is I think so shity :(.

Seems I have the same issue here like Outrunner. It's on a Radeon 9200 and prints:

java.lang.Error: Cannot create window: No support for WGL_ARB_multisample

at com.jme.system.lwjgl.LWJGLDisplaySystem.initDisplay(Unknown Source)

at com.jme.system.lwjgl.LWJGLDisplaySystem.createWindow(Unknown Source)

at net.rpgtoolset.engine.RPG.initSystem(RPG.java:258)

at com.jme.app.BaseGame.start(Unknown Source)

at net.rpgtoolset.engine.RPG.main(RPG.java:80)

While other jME apps do work, of course - have you altered jME for your app?

the screenshots look very nice.

did you do the GUI all by yourself?

Outrunner and irrisor: Can you try running it again?  I didn't alter jME (at least I don't remember doing so), however going by the error message you received about multisamples I think I know what was causing it.  I was calling display.setMinSamples(2), and I'm assuming this probably isn't supported on all cards.  The appropriate jar was updated, so let me know if that helps.

sfera: Thanks!  Yes, the GUI was done on my own using Swing.  Some aspects of the interface were influenced by the Eclipse IDE however, so I should at least give some credit to it.  :slight_smile:

Good work. Are you planning to release the source?

Thanks… Not really any plans yet to release the source, but it's something I'll consider when I get further along with the project.

Yub working now, but I had to go to add/remove program remove the prev thing from the application for the new one to take effect :(.

else nice work.

Thanks, good to hear that fixed it!

Mojomonk, thanks for your feedback also, forgot to mention that earlier!

looks awesome. the first thing that comes to mind…Legend of Zelda…i love it

Nice n smooth - well done