RPG Toolset v0.2

I decided to go ahead and release what I have so far as version 0.2, you can read more details about it on the home page: http://www.rpgtoolset.net



As I mentioned on the site, I haven't done any extended testing on this, so for anyone who gives it a try let me know of any problems that you run into and I'll try to get them fixed.  This is the first version of the toolset that runs on jME, my original release ran on Xith3D.  Any sort of feedback would be appreciated, thanks!

Cool, I will give it a go soon. 



Having now worked with Xith and jME, do you have any thoughts or observations to share?  Also, how hard was the port?

Cool, thanks.  The port was fairly straightforward, mostly just time-consuming…  The tests/demos really helped a lot in getting things working.  I must admit that shadows are primarily what drew me in initially, but once I started working with jME I found it to be suited well for my project overall.  At this point it's been quite some time since I worked with Xith, but jME seems to be more developed and I found myself wishing I would have went with jME in the first place. :D  Of course, though, it was a good experience, as both Xith and jME are great tools.

Great, thanks for the feedback!  :)  Kudos on your project.

Sounds like it (Porting from Xith to jME) could be a useful page on the Wiki to me  :slight_smile:

i find it hard to recognize the text on the buttons.

the GUI is sometimes extremely unresponsive (but it always recovers after a few seconds)



i like it very much otherwise. i once wrote a map editor myself (isometric - not 3d). i might have some self-made icons for the tools somewhere in the depths of my HDD (in svg format) if you need them. otherwise, keep up the good work :wink:

some suggestions:

  • it'd be nice to be able to place "blocks" of elements on the terrain: i.e. like copy + pasting entire areas of the map (which i didn't manage to do - bug?)
  • camera navigation while a tool is selected
  • the ability to rotate tiles before placing them on the ground



    and a bug:

    i placed trees/bushes on "hill" tiles. after that i changed the tiles to "grass"(flat), but the objects on terrain weren't adjusted to be "on" the ground (they were in the air).

sfera:



The copy and paste functionality should be partially working, try doing it this way: Drag and select an area while in Select Tiles mode, right-click on the selected area and click Copy, then right-click where you want to paste and click Paste on the popup.  It for sure should work that way, but I didn't get around to testing other combinations using the Edit menu and hotkeys.  Let me know if that works…



Unless I broke it, you should be able to move the camera around in any mode by using the NumPad keys (the manual should list exactly what each key does).  I may expand on this to allow the camera to be moved by moving the mouse to the edges of the canvas or something like that.



Rotating tiles before placing them on the ground is a good idea, should be easy to implement into the Tile Selection panel.  I will probably do something similar with objects, along with an object's scale.



As for the bug, I'll try to get that fixed at some point so it automatically adjusts to the ground level.  At this point, you would just have to adjust the height of the object manually in the object properties.



The RPG Toolset look and feel is somewhat experimental, you can go to the Configuration settings and change to the Windows LAF, should be easier to see things that way.  Not sure about the unresponsiveness, I'll have to look into that.



Thanks a lot for the suggestions and feedback! :slight_smile: