Running HelloTerrain

Hello everyone,

I’m trying to run the HelloTerrain.

After updating jme3, including nightly builds, it’s not finding the alphamap.png.

I saw in a post ( that “test-project-libraries” is needed in the classpath. I haven’t been able to use this since I can’t find it.

Also, I saw in anoter post that -Djava.library.path=./lib -cp ./lib/lwjgl.jar:./lib/jogg-0.0.5.jar:./lib/jorbis-0.0.12.jar:./jme.jar:./jmetest.jar:./jmetest-data.jar:./jme-effects.jar:./jme-model.j ar:./jme-terrain.jar:./jme-ui.jar jmetest/TestChooser was needed. This solves nothing for me.

The error I’m getting is:

com.jme3.asset.AssetNotFoundException: Textures/Terrain/splat/alphamap.png (Flipped) (Mipmapped)
at com.jme3.asset.DesktopAssetManager.loadAsset(
at com.jme3.asset.DesktopAssetManager.loadTexture(
at com.jme3.asset.DesktopAssetManager.loadTexture(
at jme3test.helloworld.HelloTerrain.simpleInitApp(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(
May 8, 2012 1:28:48 PM com.jme3.renderer.lwjgl.LwjglRenderer cleanup
INFO: Deleting objects and invalidating state
May 8, 2012 1:28:48 PM com.jme3.input.lwjgl.LwjglMouseInput destroy
INFO: Mouse destroyed.
May 8, 2012 1:28:48 PM com.jme3.input.lwjgl.LwjglKeyInput destroy
INFO: Keyboard destroyed.
May 8, 2012 1:28:48 PM com.jme3.system.lwjgl.LwjglAbstractDisplay deinitInThread
INFO: Display destroyed.
BUILD SUCCESSFUL (total time: 4 seconds)

Anyone sees the problem?


The problem isn’t in the software but how you run it, you probably miss a lot of jar files. How do you compile and run it?


Ok so this is what I did so far:

  1. downloaded & installed & updated jme3
  2. Did the Hello SimpleApplication tutorial (New Project wizard, select the template JME3→Basic Game). Created a package & a class where I pasted the code and hit right button→Run file
  3. In the same project, created a new package & a class for HelloTerrain where I pasted the code of the tutorial.
  4. Hit right button→Run file
  5. Didn’t work so went to select project → right click → properties → Run → Arguments and added “-Djava.library.path=./lib -cp ./lib/lwjgl.jar:./lib/jogg-0.0.5.jar:./lib/jorbis-0.0.12.jar:./jme.jar:./jmetest.jar:./jmetest-data.jar:./jme-effects.jar:./jme-model.j ar:./jme-terrain.jar:./jme-ui.jar jmetest/TestChooser” (still doesn’t work).

    Is there anything else I should check for?

From “Hello Assets”:

When I tried that I got “Library jme3-test-data already exits”.

But I can’t find any Library with that name on the list

show us a screenshot please

I figured out the problem. I was looking for a library that was called “jme3-test-data”. When I added the two libs, the terrain one and another one.

I don’t know how to tell you the name of the other because I can’t find the jme3 application. Newbie problems… :frowning:

So the names of the libraries were jme3-libraries-terrain and jme3-test-data.