Running jme3 alpha 4

I have donwloaded jme3 alpha 4 from SVN. How can I run it?

We are already in Beta. Alpha was deprecated. Download the Beta and run it by double clicking it.

i have downloaded the beta already.But no way it is not working,

Could you be more explicit, how is it not working ?



Why didn’t you try the jME Platform to begin with ?

i have downloaded the beta already.But no way it is not working,


I'm talking about the SDK. The plataform. Btw it sounds like you don't wanna our help. You didn't give enough informations. Lol.

I’m talking about the SDK. The plataform. Btw it sounds like you don’t wanna our help. You didn’t give enough informations. Lol.

why? :) I still need your help. Earlier I downloaded jme3 beta( .exe one, what is there on the site, the latest one).With that sdk , I am facing some problems.None of the examples are workig in my pC. So I searched in the forum.Already few other people also having the same issue.The solution suggested for this was to download this alpha version, http://code.google.com/p/jmonkeyengine/source/browse/#svn%2Fbranches%2Fstable-alpha4.With the alpha version the examples were working for that particular 'user'. So I want to try it out.If I have correctly understood it, I also downloaded this version from the SVN,but no idea how to run this as it is having lot of projects in it.Hope I clarified my issues well here this time.

If you are using the Alpha one, you won’t be able to update it, then it will run into problems. Btw what doesn’t work for you?Is it an installation issue or not?

Given that you don’t already know how to track down what to do with the raw SVN checkout, I’m going to go out on a limb and suggest that figuring out why beta doesn’t work is going to be much easier than trying to build the source yourself.


If you are using the Alpha one, you won’t be able to update it, then it will run into problems. Btw what doesn’t work for you?Is it an installation issue or not?

I am getting this error when run the applications.
com.jme3.renderer.RendererException: non-power-of-2 framebuffer textures are not supported by the video hardware.
why I am getting this error? I am able to run jme2 without any problem.
@gamerfan said:
I am getting this error when run the applications.
com.jme3.renderer.RendererException: non-power-of-2 framebuffer textures are not supported by the video hardware.
why I am getting this error? I am able to run jme2 without any problem.


Do you get this when you run the beta SDK itself or only when running the test apps? If you can run the SDK have you let it update to the latest stable release?

And what’s your graphic card and what was the driver you’ve installed?

Please find the details:

Using LWJGL 2.8.1

Offscreen buffer created.

Adapter: atiumdag

Driver Version: 7.14.10.517

Vendor: ATI Technologies Inc.

OpenGL Version: 2.0.6747 Release

Renderer: ATI Radeon X1200

GLSL Ver: 1.10

Hmm. Make sure your driver is up to date. Btw if you wanna know what are the supported features of your graphic card in jme, read this https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:advanced:read_graphic_card_capabilites.

non-power-of-2 framebuffer textures are not supported by the video hardware.

Somehow you are using a texture with a size that is not a power of two (2^n like 256x256, 512x512, ...). Your GPU / driver doesn't like "npot". The textures from test-data are power of two afaik.

…but this is why I ask questions that are never answered. There was a bug in the NPOT detection and so if the poster is not up to date with the latest beta stable update then they might get that error even with valid textures that are not square or whatever.



If they can’t even run the best SDK at all then there is a deeper problem… but questions must be answered before help can be offered.


Hmm. Make sure your driver is up to date. Btw if you wanna know what are the supported features of your graphic card in jme, read this https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:advanced:read_graphic_card_capabilites.

This are the details:
Jan 13, 2012 11:20:04 PM com.jme3.renderer.lwjgl.LwjglRenderer initialize
INFO: Caps: [FrameBuffer, FrameBufferMRT, OpenGL20, ARBprogram, GLSL100, GLSL110, TextureCompressionLATC]

Well. If you said what doesn’t work are the projects, then it isn’t a SDK issue at all. It have absolutely nothing to do with the SDK, but maybe with the graphic card or with libralies out of date. Alpha is deprecated. But you can use the OpenGL 1 with jme3, and the OpenGL 1 or LWJGL canvas with the SDK Beta. Btw, go to the http://jmonkeyengine.com/ site and run the applet or webstart demos to see what are the samples that work for you.


Btw, go to the http://jmonkeyengine.com/ site and run the applet or webstart demos to see what are the samples that work for you.

It is not working at all.
It is not working at all.


Have you updated the graphic card drivers dude?

As far as I have known, I have not updated it,Do I need to update it?