runtime crash java.lang.NoSuchMethodError: com.jme3.scene.Mesh.getBufferList()Ljava/util/ArrayList;

Hello,

I have the following runtime exception:



GRAVE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.NoSuchMethodError: com.jme3.scene.Mesh.getBufferList()Ljava/util/ArrayList;

at com.jme3.renderer.lwjgl.LwjglRenderer.renderMeshDefault(LwjglRenderer.java:2453)

at com.jme3.renderer.lwjgl.LwjglRenderer.renderMesh(LwjglRenderer.java:2520)

at com.jme3.material.Material.render(Material.java:1040)

at com.jme3.renderer.RenderManager.renderGeometry(RenderManager.java:649)

at com.jme3.renderer.queue.RenderQueue.renderGeometryList(RenderQueue.java:299)

at com.jme3.renderer.queue.RenderQueue.renderQueue(RenderQueue.java:351)

at com.jme3.renderer.RenderManager.renderViewPortQueues(RenderManager.java:886)

at com.jme3.renderer.RenderManager.flushQueue(RenderManager.java:842)

at com.jme3.renderer.RenderManager.renderViewPort(RenderManager.java:1118)

at com.jme3.renderer.RenderManager.render(RenderManager.java:1160)

at com.jme3.app.SimpleApplication.update(SimpleApplication.java:266)

at mygame.FlyingObjectsGame.update(FlyingObjectsGame.java:171)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:149)

at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:185)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:223)

at java.lang.Thread.run(Thread.java:662)



Has anybody had this problem before? I recently updated to the nightly version to try to solve another problem. May this exception be related to having installed the nightly update?

Thanks for your help.

Seems like maybe you have a bad build or old jars hanging around. Did you update to nightly through JMP or do you manually download the jars?



The line numbers in your stack trace don’t even match up to the current source code.

http://code.google.com/p/jmonkeyengine/source/browse/trunk/engine/src/lwjgl/com/jme3/renderer/lwjgl/LwjglRenderer.java



…which was last modified on Dec 5th since Mesh was modified to use a different list class.

Hi PsPeed, I updated through JMP Help->Check for updates. My installed versions are:



JmonkeyEngine3 external libraries: Version: 3.0.0.8928

JmonkeyEngine3 library:Version: 3.0.0.8959



The libraries used in my project were added in the IDE by using the “add library” button on the properties->Libraries tree element. The classpath for these libraries is:



jMonkeyEngine3.jar: $install_dir->jmonkeyplatform->libs

all the remaining jars from … AppData-> Roaming->.jmonkeyplatform ->3.0beta->libs

Re-installing JME from scartch and going back to Stable version solved the problem.

for future search about this problem.

I had the same problem with embedding jmonkeyplatform with netbeans RCP. The problem is with conflict with the jMonkeyEngine3.jar library and jME3-*.jar libraries (in this situation with jME3-core.jar).



When creating netbeans library wrapper module I choose all libraries from jmonkeyplatform/libs directory (with the two above libraries). With this configuration the exception arises (netbeans was using jMonkeyEngine3.jar first. After removing these libraries from the wrapper all worked as a charm.