Scene Composer Problem

Hi everyone. I thought I might’ve seen a post like this one already, but I couldn’t find it, so here I am.



Okay, so, my problem is that when I try to view something in the scene composer, it comes up with an error saying, "Error in scene! (java.lang.IllegalStateException: Cannot render mesh without shader bound).



With my own scene model, I mess around with it, pressing buttons and what not, until finally the 3D collection of right angles (the multicolored thing that shows the axes) comes up. However, I can’t see the scene… Aw crap, now it’s taking forever to load -.-

… And now it froze up…



lol, I love the engine, but NetBeans is at war with me XD

lol, I thought my home computer would be different than the other computer, but it still doesn’t like NetBeans… Oh yeah, btw, it’s completely updated and everything :stuck_out_tongue:



Thanks.



-NomNom

Theres some error in the file or with your graphics card, check the small warning sign in the lower right to check the actual stack trace of the error and post it here, also go to Help->Check Graphics Capabilites and post whats listed there.

Yeah… I can’t check it now… It took half an hour to load up (unlike the 2 other times I’ve tried it) and then it froze… lol, worst luck XD

I have some similar errors:

When I try to open my fresh installed and updated jMonkeyPlatform, I get following error-popup:

Error opening OpenGL window!

and after it the SceneComposer doesn't show up
Here are the Exception thrown:
org.lwjgl.LWJGLException: X Error - disp: 0xffffffff81dee778 serial: 29 error: BadValue (integer parameter out of range for operation) request_code: 1 minor_code: 0
at org.lwjgl.opengl.LinuxDisplay.globalErrorHandler(LinuxDisplay.java:277)
at org.lwjgl.opengl.LinuxDisplay.nCreateWindow(Native Method)
at org.lwjgl.opengl.LinuxDisplay.createWindow(LinuxDisplay.java:430)
at org.lwjgl.opengl.Display.createWindow(Display.java:315)
at org.lwjgl.opengl.Display.create(Display.java:855)
at org.lwjgl.opengl.Display.create(Display.java:783)
[catch] at com.jme3.system.lwjgl.LwjglCanvas.createContext(LwjglCanvas.java:309)
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:100)
at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:206)
at java.lang.Thread.run(Thread.java:636)

java.lang.NullPointerException
at org.lwjgl.opengl.GL11.glGetString(GL11.java:1770)
[catch] at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:109)
at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:206)
at java.lang.Thread.run(Thread.java:636)

java.lang.IllegalStateException: Cannot determine close requested state of uncreated window
at org.lwjgl.opengl.Display.isCloseRequested(Display.java:581)
at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:208)
[catch] at java.lang.Thread.run(Thread.java:636)

Also Help->Check Graphics Capability freezes the jMonkeyPlatform
My system:
Ubuntu 10.10 + NVIDIA GTX260 with newest drivers

@doe300: that sounds bad, might even be broken memory or graphics card.

Yeah it sounds strange,

but all other stuff (including games on Windows XP or running JME3-apps on linux) still works

But even jme-apps detect my OpenGl-version:

...
06.03.2011 18:24:55 com.jme3.system.lwjgl.LwjglAbstractDisplay initInThread
INFO: Vendor: NVIDIA Corporation
06.03.2011 18:24:55 com.jme3.system.lwjgl.LwjglAbstractDisplay initInThread
INFO: OpenGL Version: 3.3.0 NVIDIA 260.19.29
06.03.2011 18:24:55 com.jme3.system.lwjgl.LwjglAbstractDisplay initInThread
INFO: Renderer: GeForce GTX 260/PCI/SSE2
06.03.2011 18:24:55 com.jme3.system.lwjgl.LwjglAbstractDisplay initInThread
INFO: GLSL Ver: 3.30 NVIDIA via Cg compiler
...

Is there plugin in jMonkeyPlatform, which could cause this error?

Hey guys,



I have exactly the same problem.

I am running Kubuntu 10.10 64bit (GeForce GTX 560 Ti)



If I download the fresh (unupdated) jMonkeyPlatform the scene composer works like a charm.

But once I update it to a nightly build, the scene composer is broken.



Following events will let jMP freeze forever on my machine:

  • Opening (accidently) the scenecomposer window.
  • Opening any (nifty-gui) XML file which will be loaded by the nifty-gui previewer.
  • Help → Graphics Capabilities Test.



    Everything else including running (jME3) games works. Also within the jMP.



    The windows version on the same hardware works like a charm however.

    So I don’t think it’s an hardware problem.



    If I can help somehow to isolate the problem please let me know what to do.

    Thank you for jME3!
  • superm4n

Does this happen only when the scene viewer is hidden on start? Btw the scene viewer should never be closed, that ends the opengl thread and jMP will wait forever for tasks to finish.

Hey normen!



Jesus Christ… You solved it.

If I close all windows (besides the Scene Composer which is unclosable) and restart jMP everything works again.

So like you already said: The problem occures if the Scene Composer is hidden on start.



Thanks normen! I owe you one or two.

-superm4n.

superm4n said:
Thanks normen! I owe you one or two.


So does everyone else ;)


But yeah, whenever I try to do anything with jMP, on every computer, if refuses to work. I blame NetBeans. At least it works in Eclipse ;)

Same solution here:

When I open jMonkeyPlatform with SceneComposer only opened, it works fine.

Looks like a problem with JOGL and Linux

Okay, so I reinstalled jMP, and checked my graphics capabilities:



Graphics Capabilities


FrameBuffer
FrameBufferMRT
FrameBufferMultisample
OpenGL20
OpenGL21
ARBprogram
GLSL100
GLSL110
GLSL120
FloatTexture
VertexBufferArray

Now what?

If you can check the capabilities the engine seems to start, whats the problem exactly? The main problem about this is the lwjgl canvas for the OpenGL display, we know where the problem is but have to check how exactly we work around that. Try adding a lwjgl canvas to the nonstandard eclipse SWT windowing system and check if it still runs good :stuck_out_tongue:

Hmm… I can barely move around in it, it’s really slow… DANG! It takes up all of my CPU -.- Guess I’ll have to try it on another computer tomorrow…

nomnom said:
Hmm... I can barely move around in it, it's really slow...

Can you see the jme3 stats display when you press the little "i" in the upper right of the scene viewer?

Nope…

So it cannot be started, nothing will work properly.

Guess I’ll stick with Eclipse still… Thanks for helping, normen :wink:

Well it would be nicer if you could look what the problem is, check the logs etc. for stack traces. I didn’t see any concrete error messages from your computer. Also, did you try alpha-4?

I was going to try alpha-4 on the other computer I use today. The computer that I tried earlier has a 1.1 Ghz CPU (I’m surprised it runs anything at all!), so I just kind of abandoned any hope of that ever getting a more advanced IDE working after it ran extremely slow (and took up all of my CPU… lol, the CPU was at 100% for about 5 minutes after it closed). So yeah, I’ll try it on my school computer. It looks really useful/helpful! I really hope it works this time! Thanks.



-NomNom