Scene Error

So I recently spent at least 10 hours making a scene and something happened where I ran the scene and I got a null pointer, and a problem with binary importer. I tried to undo everything but it wouldnt let me. How can I fix this? I would absolutely hate to redo it and have the same thing happen. Error:

SEVERE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
at com.jme3.export.binary.BinaryImporter.readObject(
at com.jme3.export.binary.BinaryImporter.load(
at com.jme3.export.binary.BinaryImporter.load(
at com.jme3.export.binary.BinaryImporter.load(
at com.jme3.asset.DesktopAssetManager.loadAsset(
at com.jme3.asset.DesktopAssetManager.loadModel(
at com.jme3.asset.DesktopAssetManager.loadModel(
at mygame.Main.loadTerrain(
at mygame.Main.simpleInitApp(
at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(

I found the tab where you can display the history files and I go to a file, click replace all to the current file but it doesn’t save. Is there another way to apply files from history?

@normen can you give me a solution? This is very very disapointing to me that a null pointer corrupted the entire file because it says 1kb which cannot possibly have any data. I will not continue until I have a solution because if it happens again I will be pissed beyond belief.

What version of the SDK are you using? What did you do to trigger the error in the first place? Did you keep any backups as you went?

Could you upload the J3o? It seems you’re using RC2, and I’d like to test it against last SVN.
A nullpointer should be easy to figure out, maybe your file can be restored in some way.

@zarch I was copying scene objects and adding them, ran the program, got the error and I haven’t been able to open the composer of the scene yet. It says error in scene. I am using rc2. And under the file history, it uses the net beans to crest backup patch files and I am having trouble applying the history files to the current one.

I had this happen to me during ludum dare a while back

And you fixed it by… @wezrule

I didn’t

Hopefully, he just reverted to an older version, redid the missing parts, and kept working.

We all work with a local version control system, right?

Yh what pspeed said except it was on googlecode :).

Still quite annoying to redo stuff you just did, but you’ll get used to it :slight_smile:

The manual describes how the local versioning works and how you can restore files.

I followed the manual but when I right click the .j3o files, I get the option to revert back to the history, but I can’t click on it. I don’t know if this is a jme3 glitch or I have something set up wrong.

Then there is no version in the local history anymore.

Can you just restore from your version control system?

…and if your answer is that you don’t use one then I got nothing. No VCS is like tight rope walking in a hurricane with no safety net.

I guess I tightroped in a hurricane with no net. Guess I am back to plan A but hey, a lesson learned.

@jrlowe said: I guess I tightroped in a hurricane with no net. Guess I am back to plan A but hey, a lesson learned.

Sorry you had to learn this particular lesson the hard way. :frowning:

I could spin many horrifying tales of life lessons slowly teaching me to always use revision control and to always make frequent backups. To include losing almost a years worth of artwork, writing, and code when some hard drives died within a few hours of each other. “But I backed it up to another hard drive?!?”


@jrlowe said: I guess I tightroped in a hurricane with no net. Guess I am back to plan A but hey, a lesson learned. could listen to me and upload your j3o, so I look into it. There are no guaranty, your j3o is maybe completely screwed up, but you never know if it's a NPE it's maybe just something missing somewhere... I could restore your file, and even try to understand what went wrong and help make the SDK a bit more reliable.
1 Like

I already installed and set up tortoise and am saving my work via assembla so I think it should be fine though. I had no version control previously so don’t bother trying to fix it. Most likely user error