SceneComposer doesn't save?

Every time I edit something in scene composer, it doesn’t save it. I tried Ctrl+S, tried closing and hitting save when it prompts, tried using the save button on the toolbar, to no avail. No idea why it’s not saving. Any help?

RC2, and I think it was just my computer being stupid, because it’s working now. xD Thanks anyway!

It saves to a j3o, you know that? Maybe you load the ogre file?

I’m exporting an OBJ, converting it to j3o, and trying to rearrange the hierarchy of nodes and geometries. When I add a node, name it, and put geometries in it, it doesn’t save. It doesn’t even save any renaming I do to geometries whether or not I add or change nodes. I’m loading the j3o, I made sure of that. But it’s not just that it doesn’t change when I load it. If I save it, then double click the j3o again after that, it just loads the original as if I just converted it again. I’m not clicking the OBJ to convert it again, I’m trying to open the j3o, yet it reverts each time.

Do you get any exceptions (warning sign in the lower right)?

Ah, yes I do. I didn’t even notice that. When I right click the base node of the scene, add spatial, Node, I get an exception saying something about “JmeNode[null] gets null name!” Something about naming? It automatically assigns the name “Node,” and I got this exception before trying to rename it.

@nehon, this got anything to do with the new renaming code?

mhhh i don’t know i just tested it and it works fine for me…

@vinexgames are you using RC2? Nightly?

I seem to be having a related problem…

I had a physicscontrol on a node in my scene, but when I deleted it in the scenecomposer, it seemingly dissapears, but when I reload the j3o, it’s back again!
The thing is, that the save-button does not become active when I delete the physicscontrol, so there is no way for me to save it.

I found a workaround by renaming a node i the scenegraph to make the savebutton become active, and then I was able to save the scene! :slight_smile:

As I found a workaround, it’s all good for now, but I guess you would not mind the info! :slight_smile:


Experiencing the same issue here,

I linked a model to a scene, and when I delete the model I can’t save the scene.


Product Version: jMonkeyEngine SDK 3.0RC2 Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04 System: Windows 7 version 6.1 running on amd64; Cp1252; nl_BE (jmonkeyplatform)

Looks like this problem is occurring with more people, so I thought this info might be helpful.