I just used this for the first time, and WOW. Really useful stuff!

I’ve been creating some particle emitters, and have noticed a few things:

  • Editing the properties of a Point Light doesn’t seem to prompt the Save button to light up.

  • The following properties of ParticleEmitters don’t seem to take effect in the app (although it’s correct when i open it the next time in the SceneComposer):

    ImagesX (always seem to be 1)

  • The following properties don’t appear to be saved at all (it’s set to 0.0 when i reopen it in the SceneComposer):


  • Checking “FacingVelocity” and then unchecking it, sometimes causes the effect to disappear. It will then only appear if “FacingVelocity” is checked.

1 Like

Thanks, I’ll have to update the ParticleEmitter node anyway, Momoko_Fan changed some method names etc.

Edit: ImagesX seemed to be working for me, you have to have an animated texture, I think theres some other parameter you have to activate.

Is there any way i can go about and fix some of the saving issues myself? If you give me a hint at where to look, i’ll see what i can do.

Update regarding “Images X”. Changing the property in the SceneComposer requires a reload of the object for it to take effect. It still doesn’t seem to be translated to the actual in game scene, for me.

The saving is done via a property change listener. com.jme3.gde.sceneexplorer should be the package to look in… But I guess I will fix it some time soon, you can simply workaround this by changing a Spatial parameter and setting it back so you can save.

I had a look at the ParticleEmitter node, but the properties seemed to be in order, so my problem can’t be that.

On another note:

If i have the “root node” in a scene selected, my “palette” says “no spatial selected” but i have a list of several kinds of nodes to add, i’m however not allowed to add any straight to the base node (buttons greyed out).

I would like to add some “mount points” as nodes to imported models (in this case a vehicle). The vehicle itself is a spatial and can only have lights as children.

What are my options?

Oh, it might be that theres strange behavior when a nodes name is “null”, then there might be the “no spatial selected” stuff etc…

For mount points and particle effects like smoke from a “damaged” ship etc. I’d simply create a Node for the model and attach the particle emitters, “mountpoints” (sub-nodes) and other stuff to that Node and then move around that as the model. Then you can attach stuff to the subnodes/mountpoints (which of course move with the parent) and activate/deactivate the emitters as needed for example. Another way to have “mountpoints” would be bones that move no part of the mesh. You can attach Spatials to these so they will move accordingly. This would allow you to have some animation going on for those mount points, like a ship thats being dragged to a space station etc.

It was the fact that the node’s name was null. Renaming it and some general clicking around/changing some parameters and then clicking around a bit more, and i could add Nodes.

Ah, i have a plan for adding my mount points, it’s just relying on me being able to add nodes in the first place, hence the question :slight_smile:


Here are a few more things. Consider them bug reports, feature requests, or general musings:

When editing a model (previously converted from .obj) in the Scene Composer, no added nodes or geometries (only tried those) are saved when the model is reopened. Properties are saved. Creating a new Scene and then adding nodes or geometries works as expected.

When adding a Node to a Scene, the “Update” button must be pressed for it to show up in the children list.

A Node that is added to a scene can’t be seen (no pun intended) unless you choose to move the cursor position (or some other spatial) to the node. Perhaps a way to see all object centers could be added.

It would be nice to be able to select an object by clicking on it in the view port, as opposed to having to select it from the list every time.

  1. Cant confirm that, is is possible its a model with null names?
  2. Yeah, but I dont know why :confused:
  3. The whole selection and cursor stuff is due to be extended, with widgets to transform stuff, show light radii etc…
  4. Possible for geometries, press the left button to select them (enable the “selection” button to see the selection).
1) Cant confirm that, is is possible its a model with null names?

Not impossible. I've given the root node a name, but the "save" button doesn't light up, and it doesn't save that either, when i save other things.

Mhm, might be you cant even set the name on a null-name node… Evil. :confused: Gotta get a workaround for that going.

It works when creating a new Scene, though.

That’s got a name, maybe the RootNode having a null name = death…