SceneWater example looking wierd on new computer

Hi everyone. I remember running one of the JME3 examples called SceneWater on an old ati graphics card and it worked fine. I now got JME3 on a newer computer (Uses intel HD graphics) . But now the water is all pixellated. (pink and greenish) Under all these pixels I can see the vague outline of water. I tried adjusting the settings (every possible combonation) and nothing changed. Does anyone know what might be wrong?

Never heard of this, do you have the latest graphics card drivers installed?

intel HD

Hm you might want to buy a graficcard for games anyway then…

The intel cards do support openg2.0 , but only with some hard hacks to safe performance, this results in a real crappy but mostly acceptable fast rendering.

I had the same problem, it was with the SimpleTextured lighted material, the parralax map was replaced with a few dark quads on the texture wich looked a bit identically to the real effect… :confused:

Intel HD should support at least OpenGL 2.1.

Can you post a screenshot of the issue please?

That was using OpenGL 2. Sorry I should have included a picture in the beginning. Thanks for help! I would love to figure out what is going wrong.

Looks beautiful. Unfortunately I do not have any idea what might be wrong.

Do you have the latest drivers? Download here:

I must’ve forgot my meds…

Or jME3 has a secret “trippy pixel water” feature that we just found.

I’m hoping for the latter. :wink:

Well it might be what I said, because supporting is not rendering right for intel ^^

It does not crash ( thats the support)

Alright thanks guys, I shall get a better Nvidia card (wasnt amazed with intel HD anyway as I dont think gaming is it’s highest priority.) I am preety sure it is just the intel HD graphics causing my problem as stated as I tried with ATI, NVidia and intel HD with newest drivers but intel was the only that failed (despite being one of the newest).

Thanks for the help!