SDK frame rate

Has anyone else had a weird behavior that when setting,


in one app of the SDK, that it sets it for all apps in the SDK?

That’s probably related to the way we save app settings (because your app did not have like app.setTitle() it was saved for a game named "jMonkeyEngine v3.2.0-stable)


Must need to clear some buffer somewhere because I set title before and after and didn’t change.

Do I need to clear something somewhere?

I am not exactly sure, but look into the registry under JavaSoft/Preferences I think and/or in ~/.jmonkeyengine or something

JME’s application settings are stored in Java’s user preferences:
Java Preferences API

To get a quick look at what’s going on, try

I could throttle/unthrottle the fps on the original app with or without title and everything worked for that app as expected.

Removing the cache did not help with the other apps at first.

To get the other apps to work as expected, I set the title in one app. started app (this showed no throttling), shutdown app, removed the title and now everything is fine. No interference from original app no matter what I do with it. Cache must of been screwed up.

That is plain weird.

That first chache was 6.44 gb in size.

Well that is strange, because for me it worked perfectly fine and the SDK isn’t doing anything special at all there /shrug