SDK – Framebuffer issue in SDK, not in built jar or Eclipse

I’m running into the following issue when trying to launch the various tutorial projects from the jm3 SDK.

  1. org.lwjgl.opengl.OpenGLException: Invalid framebuffer operation (1286)
  2. java.lang.illegalstateexception:framebuffer doesn’t have any renderbuffers attached

The game does run correctly, but these two errors pop up in the jm3 SDK multiple times, very quickly. It crashes the SDK fairly quickly, and only way out is to end task.

I don’t run into any issues when running the jar outside of the SDK, and I can run the tutorials fine if I build and run them from eclipse. (using nightly build).

One odd thing I noticed is that when the build from jm3 SDK, the options available are not the same as when it is launched outside the SDK. For instance, the max windowed resolution is only 1280x720, while the one built in eclipse allows windowed up to 1680x1050.

Is this due to the different jm3 releases? 3.0.RC2 vs nightly build (2013/02/25).

Any direction on what the issue could be would be helpful. I’d like to develop in the SDK vs Eclipse, but it’s not usable at the moment.

Windows 7 64bit
nvidia 660ti (up to date)
java jdk1.7.0_15

1 Like

Yes, nightly will have more windowed options and a different settings dialog.

I don’t know about your other problems. Usually the SDK only kicks out errors when I run full screen… and it doesn’t matter if I run full screen from the SDK or not usually. It will always complain and need to be closed.

Ok, I’ve just been using jm3 SDK in windowed for now. I’ll try a few different things as I go along to see if i can remedy the issue.