SDK Released for v3.2

You expect people that cannot download a torrent to program videogames?

1 Like

Just have a look at the Forums. Most dont have any programming Experience yet, however i guess we all had that dream back then

2 Likes

The young generation grew up with smart phones, they download apps from AppStore. Some of my students even have no idea about how to copy and paste a file on PC. About 1/3 of them never use PC before studying Java. :chimpanzee_lobotized:

2 Likes

Don’t laugh to hard at me but has anyone ever approached Oracle?

3 Likes

Don’t laugh to hard at me but has anyone ever approached Oracle?

I think it’s worth a try.

I think jME is a good promotion for Oracle/Java.

4 Likes

How many other Java open source projects does Oracle host huge binaries for?

…I thought the number would be around 0.

After 9 hours, I‘m nearly get it!!

The problem is that Oracle would be a special sponsorship deal again and when oracle decides to quit that we’re still stuck again. I’d rather pay a small webspace for that, I guess.

Not to speak of possible legal obligations which might occur (Think: Oracle Monkey Engine 4) :smiley:

2 Likes

How about talking to DigitalOcean?

I have found the following discussion at DO’s forum,

Quote,

[quote=, post:1, topic:38237, full:true"]We work with a lot of non-profits, educational institutions and open source projects. Please drop us an email at sponsorships@digitalocean.com with the details and we’ll do what we can to help.
[/quote]

A new release of the SDK arrived on Friday: v3.2.3-stable-sdk1!

I’ve tested it with 64-bit Windows and Linux, and it seems to work fine. Would someone please confirm that it works with OS X?

10 Likes

Hi there,

I have just downloaded JMonkey v3.2.4-stable-sdk1 (jmonkeyplatform-linux-x64.sh) from Release v3.2.4-stable-sdk1: Fix Issue that version determination got confused when a commit had t… · jMonkeyEngine/sdk · GitHub. However, I notice that the title bar has “v3.2.3” on it.

Selection_002

Thank you.

1 Like

Perhaps you already had a v3.2.3 installation and the v3.2.4 installation failed for some reason?

This issue happens on both laptop and PC using Linux Mint 19.1. I tried the following steps, but they did not work.

  1. Uninstalled the prior version of JMonkey by navigating to /home/erick/jmonkeyplatform and execute uninstall.sh
  2. Removed the folder /home/erick/jmonkeyplatform, afterward.
  3. Deleted the hidden folder /home/erick/.jmonkeyplatform and /home/erick/.jmonkeyplatform-installer.
  4. Rebooted the system.
  5. Executed /home/erick/Downloads/jmonkeyplatform-linux-x64.sh

I still see the prior version of JMonkey.

1 Like

I can confirm this. (And I used 3.2.2 before). The title bar says: “v3.2.3-stable-sdk2”

1 Like

Interesting, I tried to follow what travis did and:
here and here it used the Engine Version 3.2.4, however here it went nuts.

I COULD imagine this is happening, because this commit has two tags and the configure script just picks the first one. That would mean it’s just a display error for that matter.
I will look into that specifically.

4 Likes

Should now be fixed.

1 Like

The new v3.2.4-stable-sdk1 works for me, both on 64-bit Windows 7 and 64-bit Linux.

Be sure to install the new version (commit hash 3870a37) not the old one with the same name but a different commit hash.

I’m afraid the new 3.2.4 SDK doesn’t seem to be working for me. Whenever I try running a project with it, I get the following output:

run:
C:\Users\Test\AppData\Roaming\.jmonkeyplatform\v3.2.4-stable-sdk1\var\cache\executor-snippets\run.xml:48: 
Cancelled by user.
BUILD FAILED (total time: 7 seconds)

This happens with both the 64-bit and 32-bit Windows versions.

I can reproduce this by creating a new BasicGame project, or even a plain old “Java Application” project, with the New Project wizard, but it also happens if I open and run my existing projects. Also, if I take the BasicGame project that I created in 3.2.4, and open it with the 3.2.2 SDK, it runs absolutely fine.

This seems to be a problem that Netbeans users have encountered in the past, and the workaround has been to turn off Compile on Save, and if I do that, it fixes it for me too, however, I quite like Compile on Save, and would like to leave it switched on.

Does anyone else get this? Note that 3.2.2 works absolutely fine for me.