Seeking alpha testers for Maud

Not sure, mostly it’s recommended for Mac and Linux users which are not using property driver for gpus.
For me running app without setting core profile will produce following exception on Messa driver and LWJGL2 , but works fine with LWJGL3 even without core profile.

SEVERE: An OpenGL error has occured!
org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
	at org.lwjgl.opengl.Util.checkGLError(
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.checkGLError(
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(
	at com.jme3.system.lwjgl.LwjglDisplay.runLoop(
	at java.base/

Anyway It might not be the case with Maud, because app window opens and I see the monkey model but app froze the system and mouse or keyboard not work.

Maybe we need a third guy to give it a try also to get sure of it.

In case you like, you can upload a Maud build with LWJGL3 without jre bundled, I will test it.

1 Like

Maud depends on LWJGL v2, so an LWJGL v3 build is a non-trivial task. Also, I’m reluctant to switch to LWJGL v3 because of Issue 942.

How do JME-based games handle this setting? Should I test for platform type and set the renderer based on that?

I just tried it on Kubuntu, and I got the same behaviour. The app opens and I see the monkey, but then the system freezes. After rebooting I found the following error log in the app directory:
I hope this helps.


@sgold sounds like a Nifty gui issue ?

1 Like

Yes. I’m hoping this is just an issue with Nifty 1.4.3 and backtracking to 1.4.2 will fix it.

1 Like

I’ve uploaded version 1.0.0-alpha.7 of Maud to GitHub. It attempts to address the issues raised so far:

  • For the issue @yaRnMcDonuts raised regarding models from the asset store, code was added to sanitize null, empty, and duplicate Spatial names.
  • For the issues @raistm and @Ali_RS encountered with Linux Mint, the default OpenGL version for non-Windows platforms was changed from OPENGL2 to OPENGL33. In case the new defaults don’t work for everyone, there are new command-line options to override them:
    ./Maud --openGL2
    ./Maud --openGL33
  • For the issue @Toboi had with Kubuntu, I changed the NiftyGUI version from 1.4.3 back to 1.4.2, which is the tried-and-true version for JME 3.2.2 .

I’m eager to hear whether these changes resolve the issues.

Unfortunately I am having the same issue yet.

1 Like

I can confirm that my issue is fixed :slightly_smiling_face:
(I only tested it with OpenGL 2 though, because my hardware doesn’t support 3.3)

1 Like

I’m sorry to hear that. Are you able to run JmeTests? (In the IDE, these use LWJGL 2 and native Bullet by default.) I’m particularly curious about TestNiftyGui.

1 Like

Yes. ( only with AppSettings.LWJGL_OPENGL3) .

No problem.

1 Like

In that case, I perhaps erred in adding LWJGL_OPENGL33 to Maud. On the next iteration, I’ll include an option for LWJGL_OPENGL3.

1 Like

I’ll be testing Maud the coming days on Mac OS, eager to try some features, especially the retargeting of bone animations caught my eye!

Untill now I used my own simple ‘model-viewer’ implementation to load a model and playing/visualizing/debugging bone animations. I hope this will speed up development

edit: I need to start it up using: java -jar Maud.jar --openGL2
By default I’m presented with the error:

SEVERE: Failed to create display
java.lang.UnsupportedOperationException: Unsupported renderer: LWJGL-OpenGL33
	at com.jme3.system.lwjgl.LwjglContext.initContextFirstTime(
	at com.jme3.system.lwjgl.LwjglContext.internalCreate(
	at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(

I know I had some issues in the past running OpenGL3.3 on mac OSX. I was able to get a BasicGame running once, but I had to add some statements to the JVM and changing some settings in a org.lwjgl.system.configuration.* class. If you want I can look it up, I know I documented it somewhere…

1 Like

I think the next build will resolve the OpenGL issues. Probably tonight or tomorrow.

… Wow… !?! … Cool…

If you don’t want to try @pspeed’s thumb-drive boot, you could try a VM. Virtualbox is free, pretty simple to install, and actually supports passing through support for 3d acceleration. I have just as high a level of OpenGL support on my virtual ArchLinux development image as I do natively on my windows laptop.

(Might miss some of the device-specific oops points, but at least can check that the GL libraries load, and basically function)

1 Like

Here it is:

The command-line options have changed again. Now OpenGL2 is the default
on all platforms. On systems with non-proprietrary GPU drivers, specify the
--openGL3 option to use core OpenGL 3.2, as in:

    ./Maud --openGL3

I hope this change will allow more people to run the app.

Btw, the alternative to downloading binaries is to build Maud from source. This isn’t terribly difficult, especially if you already have Gradle installed. Maud is based on JME 3.2.2 and doesn’t depend on the engine’s master branch at all. You don’t need the latest SDK. Detailed instructions are in the README:

While not interested in running Linux today (thank you) I welcome your feedback or questions concerning Maud.

I just cloned the git repo and ran the thing from eclipse. Works fine so far.

1 Like

Thank you @raistm.

I’d love to hear from others who have tried Maud.

Version 0.3.10 of the Wes library fixes a nasty infinite-loop bug. I discovered this bug while retargeting animations using Maud. The next release of Maud will incorporate the fix.

It seems something might be broken in the buildscript :thinking:

$ git clone

$ cd Maud/

$ JAVA_HOME=/DEV/VMS/zulu8.38.0.13-ca-fx-jdk8.0.212-linux_x64  gradle build

$ cd build/libs/

$ JAVA_HOME=/DEV/VMS/zulu8.38.0.13-ca-fx-jdk8.0.212-linux_x64 java -jar Maud.jar 
no main manifest attribute, in Maud.jar

$ JAVA_HOME=/DEV/VMS/zulu8.38.0.13-ca-fx-jdk8.0.212-linux_x64 java -cp Maud.jar maud.Maud
Error: Could not find or load main class maud.Maud
Caused by: java.lang.NoClassDefFoundError: jme3utilities/nifty/GuiApplication
1 Like

I’ve not seen these issues before. You may be using an incompatible version of Gradle. Try ./gradlew build.