Shader / MaterialState Particles


I’ve got this gold coin flow

that I want to improve. So for example I tried to make it shiny, to do that, I tried to apply the same shader as I used for the gold coin pool that I’m using (you can see on the picture). However it doesn’t seem to work unfortunately …

Is it possible to apply a shader to a particle mesh ?

If not would anyone give me any advice for having my coins shine ???



maybe you can just use a better texture for the particles.

adding a light bloomrenderpass would also add a nice touch to the gold.

Or don't use particles, but use real textured coins.

I hadn't thought of the bloom render pass … will try to implement that, it could be a good idea

for the real coin model, I guess it will be my last resort since 200 coins (per flow of coin) would then represent something like 1500-2000 faces, but definitely in that case I'm sure the rendering would be hell better

Particles can support shaders too though right? Why don't you make special diffuse/normal maps for the particles then?

ahhhhhhhh !!! ok

that's what I wanted to know!!

had tried that a bit but didn't manage to have a correct result since the shader wasn't ready to deal with transparency (.tga), so I abandonned cause I thought it wasn't possible with particles, but since you told me it's possible, I just adapted it and nooow it's working, great!

can't get rid of the the transparent circle around each particle, kind of like a border effect, I tried to increase the resolution of my particle texture but it doesn't even diminish the size of this border,

thanks a lot for your advice,


Could the border result from texture compression?

after your remark, I tried to work on the texture and be sure that the transparent part was really transparent, it works perfectly when you’re close to them. However, when you take a little distance, here’s the result:

I guess it’s totally a story of compression, however this time I’m not sure I can do much since I imagine that this it the rendering that uses a compressed version of the texture in a way for I’m distant from it

I’ll have to use the real coins at some point maybe …

but thanks, at least close enough, there’s no more transparent border,


Hmm could it bee the Minification filter, which makes it look blocky from further away?

Try to play with different settings when loading the texture.