SimEthereal basic example - plus public server

thanks man
It was a nice feeling in space . :grinning:
I want to integrate my recently finished chat GUI for may game which is written with Lemur to networked chat system.
Lots of fun is waiting for me.

Well, presuming your networking is based on SpiderMonkey you can probably drop in my chat classes directly and just hook them up to your UI.

Thanks for connecting… it was nice to see someone else able to connect and fly around. :slight_smile:

1 Like

Yep, works (connected) well. Just want to inform :smiley: .

Works. Nice. Only two people in space, but still managed to crash into each other. Luckily there’s no physics (yet). ^^


Gotta give this a try tommorow. Also a read of the source.

Glad you guys were able to try it out… and that it actually worked. Heheh.

In your textfield - how’d you get the position for the cursor?

I’m currently struggeling with BitmapText having everything declared private - so I can’t access the individual glyphs. I thought maybe observe the quads from the vertex buffer - but that may be missleading since some quads have smaller xadvance than their width. But if everything else fails I will try to read that vertex buffer and use that as a hint to where individual letters are.

The code is available. Look for TextEntryComponent in the Lemur source code.

I think I do a “get size” with the characters up to the cursor. It is less than ideal.

Someday I will refactor how BitmapText outputs its glyphs so we can do more advanced stuff. As it stands, characters can overlap so even my approach is kind of broken.

→ uses:

// We add an extra space to properly advance (since often
// the space character only has a width of 1 but will advance
// far) then we subtract that space width back.
float x = font.getLineWidth(row + " ");
x -= font.getLineWidth(" ");

Ah, I completely forgot that you could do that with BitmapFont.

Tried to clone, then built the prerequisite Si02

gradlew install

and got:

:compileJava FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Could not find tools.jar

Seems like you don’t have JAVA_HOME set for your JDK.

1 Like

simethereal install

1 error
51 warnings
:javadoc FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':javadoc'.
> Javadoc generation failed. Generated Javadoc options file (useful for troubles

What was the error?


Thanks. I’ve applied the patch.

I’ve just uploaded version 3 which include the new Lemur key/gamepad UI navigation as well as the network stats screens mentioned in other threads.


Help screen:

Release is here (also added a link in the main post):

i have this error
Uncaught exception thrown in Thread[jME3 Main,5,main]
RuntimeException: Method not found for:stop on type:mygame.Main@749070fc
SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See SLF4J Error Codes for further details.
Setting root JUL log level to:OFF
AL lib: (EE) alc_cleanup: 1 device not closed

Exception: java.lang.NullPointerException thrown from the UncaughtExceptionHandler in thread “jME3 Main”

Please add the whole stacktrace and don’t forget to use code blocks. Otherwise it will be very difficult to debug the NPE. Could you explain what you did before this error occurred?

i find the problem
i upload the all library to my project

Glad you solved it and thanks for reporting your solution.