SimpleGame does not start. No error reporting :(

Helle community,

i installed everything correctly but very simple tests are not successed :frowning:

A window appears for 1 second than java terminated. No error at all. Native libs and everything is right.

After choosing my properties it terminate without error. Tried same with only one Display.createwindow … same thing :frowning:

Hope you can help me! Thanks a lot!


import com.jme.bounding.BoundingBox;
import com.jme.math.Vector3f;
import com.jme.scene.shape.Sphere;

public class Main extends SimpleGame {
    * Main method is the entry point for this lesson. It creates a SimpleGame
    * and tells the dialog to always appear. It then starts the main loop.
    * @param args
   public static void main(String[] args) {
      Main app = new Main();

   protected void simpleInitGame() {
      Sphere s = new Sphere("Sphere", 30, 30, 25);
      s.setLocalTranslation(new Vector3f(0, 0, -40));
      s.setModelBound(new BoundingBox());


Console :

30.11.2009 11:17:18 start
INFO: Application started.
30.11.2009 11:17:19 com.jme.system.PropertiesGameSettings <init>
INFO: PropertiesGameSettings created
30.11.2009 11:17:19 com.jme.system.PropertiesGameSettings load
INFO: Read properties
30.11.2009 11:17:26 com.jme.system.PropertiesGameSettings save
INFO: Saved properties
30.11.2009 11:17:26 initSystem
INFO: jME2 Main Trunk @ Google Code
30.11.2009 11:17:26 com.jme.input.joystick.DummyJoystickInput <init>
INFO: Joystick support is disabled
30.11.2009 11:17:26 com.jme.system.lwjgl.LWJGLDisplaySystem <init>
INFO: LWJGL Display System created.

I don't know why it terminates after one second… I tried running your code and it should show an empty window until you close it (you have forgotten "rootNode.attachChild(s);" at the end, so nothing is ever drawn).

Try adding the sphere to the rootnode and see if it works. Does the examples that come with jME work?

thanks for your answer!

thats the point. a black window appears for half a second and close automatically. same at the code down here.

Please look at this.

   public static void main(String[] args) {
      DisplaySystem display = DisplaySystem.getDisplaySystem("LWJGL");
      display.createWindow(1024, 768, 32, 60, true);

Console output ...

30.11.2009 13:30:45 com.jme.input.joystick.DummyJoystickInput <init>
INFO: Joystick support is disabled
30.11.2009 13:30:45 com.jme.system.lwjgl.LWJGLDisplaySystem <init>
INFO: LWJGL Display System created.
30.11.2009 13:30:45 com.jme.system.lwjgl.LWJGLDisplaySystem getValidDisplayMode
INFO: Selected DisplayMode: 1024 x 768 x 32 @60Hz

Yout see my app does not reach


Cannot explain why :( No error at all!

Thans for helping me!

Ohhhhh sorry for an other post…

seems i have problems with each openGL app.

Does HD 3650 Mobility not support OpenGL ?

hmm, your graphics card shouldn't be the problem…

I have never heard of a problem like this, but one thing I can think of is that you debug the application and step through what happens when you execute "createWindow". When you get to that command, press F7 (if your using netbeans) to step into functions. try to find out exacly where it crashes and which class/function it happens in and post it back here.

Could be a driver issue. I think I had something like that on my laptop (ati9700m) before switching graphics driver.

Ok guys i solved it :smiley:

Was a problem with HD 3650 mobility driver. I modded the new catalyst and there is a bug at the modding tool.

For those who have same problems :

thanks for helping! Works now!