SimpleWaterProcessor is showing black area on some machines

Hi Guys,
Today I was teaching ~180 students computer programming online and some of them reported seeing black area when applying the SimpleWaterProcessor in their scenes.
Is it a known issue with known workaround?


hmm, im not sure if i had something similar. But i dont remember what it was.

could you try set on/off some of Filters?

It’s the only filter we are using. It works on most machines but not for some of them…

Are all the machines the same? The main point of the question is what is the difference between the ones that work and the ones that don’t.

Same machines? Same operating system? Same java version? etc…

Most of them are different machines. 180 students online. Most of them had Windows 10 but everything else is unknown

At home, I have two laptops running windows 10 and Java 1.7.08 and on one of them I can see the black water problem

What graphics card is in the one that shows black?

Are you all running the same jmonkeyengine version?

Intel HD Graphics 5500
We are all running the same JME version

On the laptop that it works fine I have Intel HD graphics 3000

He first thing I would check is that you are using the latest drivers and not just the ones that come with windows.

Either from the manufacturer or from intel.

when applying the SimpleWaterProcessor in their scenes.

could we see code you use to demonstrate SimpleWaterProcessor?

btw. did you tried run JME water tests? (did it had same result?).

myself i dont have a lot testing computers, but it works for all of it.
if it is about drivers, then there should be just error imo. its odd behaviour.

fact is here we have Windows 8.1 and Centos linux systems only.
Windows 10 is really odd as i know, so could be also system that “block” something or do something unexpected.

The only other easy check you can do is use LWJGL3 and see if that works. Given it’s a one liner you may as well give it a go before you start “unraveling”.

can you post a screenshot?

The kids are downloading my dev. environment from that link:

Then they type the following code: "lagoon"
wait 60 seconds

They are too young to write actual Java code
I’ll post here the actual behind the scene Java code later


I had a similar problem except it depended on where the character loaded into the game when near water.

Never figured it out. Are all characters loading at the same point? If so, try moving the start spot a little and see if it still happens.

I chalked mine up to drivers and since I can’t update them I was stuck.