SkyFactory problem

Edit* : after importing the jme3-test-data library and using “Textures/Sky/Bright/”, I have a working skybox. The problem seems to be either 1) the image file format or 2) the folder / location of my jpg. Will continue farting around with it…

Im very new to jMonkey, and have been humming along mostly nicely, but this simple one has me stumped.

public void simpleInitApp() {

//did stuff here…




//I have tried this


// “Textures/skybox.jpg”,

// false));

//as well

//more stuff here


It builds and runs fine, but no sky box is visible in the game.

The texture is named correctly, in the right place (Im sure because I have a textured box that works fine with a jpg in the same folder).

I have a 512x512 jpg as the box (I noticed non power of 2 images dont work with regular textures so I set it to 512x512)

I have tried other images / formats / sizes too, same result.

I have gone over the documentation “How to add a sky to your scene” here :[]=skyfactory

I have looked for info on the SkyFactory class here : and could not find anything :frowning:

I have searched the forums and only found 4 mentions of SkyFactory, none of which offered a solution I could use.

I have sacraficed an offering to Mota. Nothing.

Try to remove the RootNode’s culling, I had a similar problem in this thread :

Of course it’s not a permanent solution. You will have to find out how to manage your objects if this works out.

Heya ozonegrif,

Regarding : “…Try to remove the RootNode’s culling…”


Geometry sky = new Geometry(“Sky”, sphereMesh);



I thought those 2 functions were called automatically when you call SkyFactory.createSky(…)[]=skyfactory

“Internally, the SkyFactory calls the following methods:

sky.setQueueBucket(Bucket.Sky); makes certain the sky is rendered in the right order, behind everything else.

sky.setCullHint(Spatial.CullHint.Never); makes certain that the sky is never culled.”

Setting SkyFactory to use a spherical map works… this is the darndest bug…




SkyFactory sets the sky’s Culling, not the RootNode’s Culling.

In the thread I point you, I tried to remove the RootNode’s Culling, and it solved the problem for me.

They also suggested to scale the sky spatial to make it bigger and prevent the Culling. Everything is explained in this other thread.