Smoothing the model


I’ve recently added a character to my scene. The character is loaded from the ogre file.

It is exported from Blender and when loaded in jme it looks terrible.

How can I make it look smoother ??

Looks like a normals mess…

before exporting, be sure every modifiers are applied on the mesh (especially if you have a smooth modifier).

if it does not work, in blender go to edit mode select all, crtl+N, recalculate normals.

then type F9 and click on the “set Smooth” button.

The normals are fine. I checked everything when exporting from blender.

All normals are calculated outside.

I thought there may be some rendering options I didn’t set.

In Blender the same model looks smooth when applied a texture. And of course increasing the number of vertices

isn’t an option. There are a lot verts already.

could you upload your blend file so i could test?

Could it be, that your faces and vertices aren’t connect to each other? Best you upload the file, than we examine the patient :wink:

Ok here’s the patient :slight_smile:

Link to the blend file

Treat her well, she’s very famous :smiley: