[SOLVED] 3.0 to 3.1 Asset Load Error Android

Hi there,

I’m currently porting one of my applications over to jmonkey 3.1.

It’s gone pretty smoothly so far as I’ve got the game running in 3.1 and I’m trying to get it working on Android.

My splash screen displays my google play advertisement pops up but it crashes with an Asset Load error:

E/com.jme3.app.AndroidHarness(16014): com.jme3.asset.AssetLoadException: An exception has occured while loading asset: Textures/Hay.jpg (Mipmapped)

Complete Stack Trace:

Thanks for reading

EDIT: I notice it’s using the “Desktop Asset Manager” Perhaps this is the reason?

EDIT: Solved By Exporting Hay.jpg to Hay.png

Did you try using a non-progressive jpg? When you export from gimp, you need to uncheck the progressive option if you are targeting android.

1 Like


I had no idea what the problem was to be honest. This was the same image I had uesd previously in the game.

That may have been the problem.

My current problem is still this:

Very sorry but I know nothing about jme terrain. I’d make sure your asset paths don’t start with a leading “/” and jpg textures should be non-progressives for android but don’t know anything else.

Have you tried the terrain test with android see if that works?