[Solved] animation flipped

hi guys



i m troubled again with animation issues

(and be sure i dont come here everytime i have a little problem i cant fix within 5minutes of thinking myself)



my animation seems to do some akward things while exporting the animation cuz it seems the bones are flipped while exporting



for example :

i have a figure with a walk-animation

if i do the walk animation within blender (2.49b) the arms are attached to the shoulders, but in jme3 (sceneviewer and simpleapplication) it looks like the arms are attached to the hips



looks funny…but isnt to good :slight_smile:



the arms arent the only parts that looks odd…in fact it seems the whole bunch of bones are somehow mixed up…



any hints? any settings i m somehow missing?



would be great if i could receive help again! :slight_smile:



thx in advance

Terry

Did you read this:

try to apply rotation/scales/location on your mesh in blender.

Make sure that the model in edit mode is well positioned on the armature in rest position

@normen

well the link helped to get the animation :slight_smile:

so yes i read this earlier and didnt helped me for this aspect

though the reorient methode sounds like it would be the right thing though it didnt helped me … :frowning:



@nehon

i tryed out some secs ago and still same result… :frowning:

the last hours were again some frustrating ones

still the same issue… and i dunno why…



if it is any help here the blend file

http://rapidshare.com/files/453362644/Figur.blend



though i do exactly the same thing, as this link says :

https://docs.google.com/leaf?id=0B9hhZie2D-fEYmRkMTYwN2YtMzQ0My00NTM4LThhOTYtZTk1MTRlYTNjYTc3&hl=en



thx in advance

terry

Your model and your armature have un-applied scales and position, this is what’s wrong.



to apply scale and position in blender 2.56 go to the “object” menu in 3D view “apply”/“location” then do it again for “scale”.



in blender 2.49 you can apply rotation and scales but not location go to the object menu then “Clear/Apply”, “Apply scales/rotation to objdata”. do this on both the model and the armature one by one in Object mode.

then select your armature and hit Alt+G, this will clear the position. Then go to edit mode and re-position the armature on the model (use “g” and “z” and move it up).



then it should work

1 Like

yeah it worked :slight_smile:



sorry that i missunderstood ur hint at first…but the detailed explanation was a great help!



i really appreciate this forums help!

u guys are great :slight_smile:



Terry