[SOLVED] Animation not working in sdk scene composer

Hi everyone,

I created a conveyor belt bone animation in blender and converted it in to j3o using the sdk. When I try to play the animation in the scene composer nothing happens. I even baked it and still nothing happened.

This is how it looks in the scene explorer:
Selection_011

This is how it looks in blender:
Selection_012

I already went through the tutorial checklist of “Creating assets in Blender 3D” I don’t know how many times.

Does anyone have any idea what else I can check?

Cheers!

i would like to ask some questions:

  • what SDK version?
  • what Engine Version?(if not same as default SDK Ant one)
  • what exporter do you use? (i suggest GLTF https://wiki.jmonkeyengine.org/jme3/external/blender/blender_gltf.html)
  • What Blender version do you use? 2.8 or lower? (gui looks like lower version)
  • how your NLA look in Blender.
  • please provide link to exact wiki you used as tutorial.

also:

  • make sure to do ctrl-a -> apply all tranforms in blender.
  • if animation do nothing, maybe you see animation from “current NLA track” while exporter export other NLA track. etc etc.
  • sdk v3.2.4-stable-sdk1
  • I don’t know where I can find out the engine version
  • no exporter. I right click on the blender file in the sdk and click on “convert to j3o binary”
  • the blender version that comes with the sdk version is still 2.79…
  • nla:
    Selection_014
  • here is the tutorial: https://wiki.jmonkeyengine.org/jme3/external/blender.html

yeah… the all transforms I already did…

if im not wrong, in NLA it should be only under Armature, not Vertex Group(but well i might be wrong)

this dont help me much to know the reason tho. But maybe someone else will know.

But, just to tell you, .Blend(because each version have different api) and .ogre(because deprecated kind of) exporters are very unstable. Current stable exporters are .obj / .gltf as example.

Maybe its because SDK 3.2.4 is compatible with Blender 2.8+ only? idk.

What i can tell you is rather some information. Myself i had issues with .blend exporter before, because it often break on different blender versions(because blender each version can change it).

So i can just suggest use .obj(static models) and .gltf(animated models) and using Blender 2.8+.
This seems stable and GLTF is new game export standard

  • Blender 2.8+ -> export -> gltf
  • SDK -> second click on GLTF -> convert to j3o (or just use gltf format, also possible)

i think you could try see link i provided earlier. For me it works very well. Both animations / shape keys and material export. But you also would need to know it export PBR material. so if you want older shader, you would need replace it manually via sdk or code.

1 Like

No, .blend files from 2.8+ don’t work at all. Support of the .blend format sort of stopped at 2.79 until someone wants to continue maintaining it like Sisyphus and his rock.

1 Like

ok! It worked !!! Thank you very much!!! :smile: :tada:

2 Likes

im glad it worked.

@pspeed @mitm
Really its not first time people have issues with .blend here.
I hope wiki will soon be get rid of .Blend exporter.
Its n-th topic where i suggest GLTF and people just say “it works”

One of my first tasks after I get beta2 out the door (eventually) is to move the blend support into its own separate project in jme-contrib. If someone wants to continue maintaining it, create a store page, whatever then they can.

…as a separate project it could also be GPL and resurrect the source code that was deleted.

1 Like

Unfortunately blender is included in the sdk.

It has a custom setup that overrides the default window also so it is very confusing and not very intuitive.

Its really just bloat at this moment.

The convert button should be removed to.

yes, i understand what you mean.

I just mean people somehow first try .Blend as they think its default and should work perfectly.

I will redesign the whole blender page but it will eventually be removed from the engine wiki into the sdk or some other tutorial specific place. It doesn’t belong there.

1 Like

Did GLTF work or the fact that you moved the animation below Armature?

1 Like

GLTF worked and I didn’t even have to bake my animations, which was much simpler.
I also didn’t have to apply “all transforms” in Blender.

Also, this is not related to the topic but to the sdk: When I change the .gltf file, the sdk asks me if I also want to update the .j3o file. This always results in an error and I first have to delete the .j3o file and then click on the .gltf file and convert it into .j3o binary once more.

2 Likes

Any error log or trace?

1 Like

Selection_017

I’m using Ubuntu 18.04 if that is important…

3 Likes