[SOLVED] Blender in the SDK


#1

Given all the SDK installs I’ve done during the past year, I was surprised to discover that I don’t have Blender 3D installed on my computer.

I seem to recall that installing the SDK automatically installed Blender 3D. Is that no longer the case?


#2

I don’t think it’s installed so much as made available. It’s there but no icons are created or operating system specific acknowledgement of its presence or anything like that.


#3

I keep expecting that if I double-click on a .blend file in the Projects tab or the Files tab, the SDK will open the file in Blender 3D. Instead, I get a dialog saying that the file contains binary data and asking whether I’m sure I want to open it in the text editor.

I can open .blend files using the Open in System option in the file’s popup menu, but it’s less convenient.


#4

I can tell you that double-click and right mouse button / open in blender work in 3.2.1-sdk3.

Maybe your associations are messed up.


#5

I’m on Windows 7 running 3.2.2-stable-sdk1. How could I check my associations?


#6

Control Panel -> Default Programs


#7

Control Panel -> Default Programs -> Set Associations shows that Windows knows .blend is associated with Blender app. (It would have to be, in order for Open in System to work, right?)

I’m thinking there must be something in the IDE overriding such Windows associations when I double-click in the IDE. For instance, the IDE opens .png files using PixelHead, which is not what my system does by default.


#8

What do you see in the SDK under

tools->options->miscellaneous->files->file extension->blend


#9

There’s no item for “blend” in the File Extension drop-down list.


#10

Theres the problem then.

If you select any file type then open the associated file type drop down do you see,

Blender Files( application/blender)

in the list?


#11

Nope.


#12

On my system, 3.2.1-stable-sdk3 opens .blend files when I double click, so I suspect this is a regression.


#13

Did you install from zip?

Edit:
Since already had 3.2.1 I am not sure it would matter.

Might need to get @Darkchaos in on this.


#14

Both 3.2.1-stable-sdk3 and 3.2.2-stable-sdk1 were installed from EXEs downloaded from GitHub.


#15

So:

  1. Blender is bundled when you install the SDK by .exe, that’s why the file is much larger than the zip (which does neither contain blender nor the jdk)
  2. Blender is bundled inside the blender/ folder of the SDK Installation directory, I guess. It is not installed system white but double clicking should work yes
  3. You can test blender integration e.g. by right-click-converting fbx files, that should convert the file to blend by using blender and then load the blend file with the blender importer (so don’t expect it to be good).

This should’ve never changed since 3.0, so I can only assume that maybe the associations got messed up? So my only suggestions would be try to get the association to work or backupping settings and reinstalling/restarting the sdk when the folder is missing


#16

Thanks. I’ll try a fresh install.


#17

I just discovered that my “Blender, XBUF and GLTF Support” plugin was deactivated. Activating the plugin resolved my issue.