[SOLVED] Building is failing all of the sudden, even from scratch

Well, apparently I broke something… One moment everything was working fine, and a second later it wasn’t :sob:

As soon as I try to run my Main.java, the Output window tells me:

So, I Googled, checked the forum and in the end I decided to remove JME3.1, download it and install it again, but without any luck. When I create a new project (BasicGame) and try to launch it, same message pops up and nothing happends anymore.

Anyone has any idea what went wrong here? And even better: What do I need to do to fix it?


1 Like

Are you running on nVidia graphics hardware, and have you updated your driver recently? A recent nVidia update borked out their OpenGL implementation pretty severely. With that Java error code, my guess is that something in the native layer is causing the VM to crash - others on the forums have been having similar issues with the nVidia OpenGL bug.


Now you mention it: The graphics is indeed NVIDIA and i was updating it… After reverting to the previous version it works again!

Thanks @Darkchaos and @danielp


Awesome, glad to hear it. :slight_smile:

Just wanted to drop a line and let you all know that this fix worked for me as well. Thank you!