[SOLVED] Cannot see blender animations after converting to j3o


I am new to Jmonkey, and am having a lot of trouble getting blender animations to work on JME3. I am using the default converter to import and convert blender files to j3o.

In release JME 3.2, when I import the blend file and convert it to j3o, I do not even see the AnimControl in the scene explorer tree. After getting help in a post earlier this week, I switched to using JME 3.0 to do the conversion, and I see the AnimControl Node in the Scene Explorer tree. Imgur: The magic of the Internet

The animations work perfectly fine on the NLA editor on blender

Original file with the Animations on the armature - https://drive.google.com/open?id=1YTKQL4izO0DIN7AgXZDHLnYUILUwrfdE

Modified blender file with animation channels added to the node with AnimControl: https://drive.google.com/open?id=1VNjBWxThs4A6vtU9IDYzleSfdDiy_Q1D

I couldn’t find the solution in all the earlier posts I looked into (Most of them use OGRE for exporting animations). I think I might be missing something basic here, did anyone come across a similar issue, or have the solution for my issue?


I looked at this and you need to at least get it ready for importing before you do anything else.

Ill get you started,
Name your object under the object tab the same as the mesh fish_bulb.
Name the material the same way.

In the UV Editing layout, select your mesh and tab into edit mode, hit the “A” key until the mesh is highlighted.
You already unwrapped it but the image is missing. You have one listed in the buffer called bulb_texture.png so either load it or create a new image and bake your textures.

Load that image or the baked image after saving into the texture tab because you are missing that also. When you load it, in the image panel, click the little square box under the word “Source” to pack the image. This will allow it to be imported/exported to the SDK.

Next read creating-models ,

because most of this will fix most of your remaining problems.

Then I will look at it again to help with the rest.


Thank you for your response.

Updated file with the Image + additional changes: https://drive.google.com/open?id=1BXUcKTP1ZQqOOiSTdshRqb5Ut2_r_BkX

I renamed the object and texture to fish_blub. I did not attach blub_texture.png earlier, as my problem was related to animation, I added this to the zipped folder now.

I followed the checklist in the “creating-models” guide. My file already adheres to most of the suggestions. I changed the Armature’s origin point and the Mesh’s origin point to be the same.

However, I’m still seeing the issue that I originally started with, i.e I cannot see the animations on the converted j3o file.

Name the object in the object tab after the fish_bulb.

Under modifiers, add a triangulate modifier. If you use ogre you don’t have to apply it but with Blender import you do.

Using blender importer you have to bake your actions, not use NLA strip, that’s why you don’t see them. With ogre use NLA strips.
To bake see,

With NLA, your done already except your time line needs to equal the length of ALL animation length combined. Hit the “N” key with mouse inside the NLA editor window, select the last animation and you will see the end frame number for your timeline. Its a good idea to add a 4 frame gap between the animations also.

With ogre, in object mode, select the model and armature and export it, with blender importer, import button from SDK.

Here is the ogre script,
Here are ogre tips for export,

After blender import, you will need to delete all the crap like lights and camera, ie clean up the file in the SDK SceneComposer.

With Ogre, your done.

Forgot to mention, if you will be moving the model in the scene, it should never be moved from center origin. If all you plan for this animation to do is sit in one spot and play a fish swimming, then moving it from the center origin point like you do is fine.

Last, you will shortly find out that not adding the root bone and centering the base of the bone and models origin at same place is going to cause you grief. A root bone is not a deformable bone either. When you add one, just uncheck deform in the bone panel. The root bone is the parent of all other bones so all you need to do is select the armature first, then the root bone and parent it.


I switched to using the OGRE format, and I see the animations now. I will follow the checklist guide for every new model I create in Blender. Thank you for all the help and suggestions, really appreciate it!!