[SOLVED] Cannot texture correctly in jmonkey?

Lately I’ve been faced with a problem probably ridiculously simple to solve, but I can’t quite solve it; I’ve created a custom mesh of a gear in Blender, which I can’t show you here, I can only put one image in a post (I’m a newbie).

Then I imported it into the jmonkey sdk and converted it from a .blend to a .j3o file, and the gear, quite impressively, shows up when I run my project. However, I seem to be suffering from some lack of knowledge about this procedure, because my gear’s texture (wood) only shows on a select few faces, and the rest of the gear is simply brown:

However, in blender, the uv map appears correct, and the gear looks fine. (in case you ask, I have tried using normal textures instead of the uv map, it doesn’t make a difference)

…And I can’t see anything disastrously wrong with my code:

Material wood = new Material(assetManager, "Common/MatDefs/Misc/Unshaded.j3md");
Texture woodtex = assetManager.loadTexture(new TextureKey("Textures/wood-texture.jpg",false));
wood.setTexture("ColorMap", woodtex);

To summarize, my gear won't texture properly, and I'm not sure why. :sleepy:
Any help is greatly appreciated.


Wow! That was quick.

Silly me, I forgot to set mapping to uv in the panel in blender mentioned in the documentation you gave me.

I guess I assumed blender would automatically set this upon my uv unwrap.

Thanks a lot, my gear looks fine now:

Of course, I will need to correct my mesh - the uv isn’t too pretty.

Glad you got it sorted =) when you have a spare minute, could you please prefix ‘[SOLVED]’ to your thread title for future reference.