[SOLVED] Can't find a 32bit JME3 installer

I’m an Android :iphone: user, I want to develop with the Jmonkeyengine, but can’t find a reliable option yet :cry:
I have Ubuntu installed and can run some command (like Java -version, Java main.java)
I’m left with installing the JMonkeyengine, but my device is a 32bit. Found some links (like: jme3-sdk-linux-32bit) but can’t see something useful (can’t open the link. 404 Error or is a private blah blah <can’t remember>)
Please :disappointed: is there a way of getting Jmonkey_platform_linux×32.sh (32bit installer).
I appreciate all your efforts towards this && thanks in advance :grin:

1 Like

https://github.com/jMonkeyEngine/sdk/releases/tag/v3.2.2-stable-sdk1 is the last supported 32bit version.
But: you can also run the zip on your OS, it lacks java (you already have it installed) and Blender (Model Edition Software, you can install it manually as well).

Note that I am confused about Android and Ubuntu: You want to develop for Android on your Laptop which is Ubuntu? Because running Ubuntu on an Android Tablet might be a challenging thing for gamedev.

1 Like

@Darkchaos I have a terminal emulator (termux)
I then install Ubuntu inside Ubuntu I installed jdk8
I don’t know which Sdk to download for 32bit

@Darkchaos among them pls which should I download for my device

https://github.com/jMonkeyEngine/sdk/releases/download/v3.2.2-stable-sdk1/jmonkeyplatform-linux-x86.sh

2 Likes

@tonihele Pls is it for 32bit

Yes. x86 is 32-bit and x64 is 64-bit

1 Like

@tonihele Thank you very much :open_hands:

2 Likes

@tonihele please after downloading it I executed it but it gave an error
the /x/jmonkeyplatform.sh seem to be corrupted
Any clue please

@Darkchaos I have the zip but don’t know how to install it

Are you still trying to install the SDK (software development kit) IDE on your phone?

…because as stated in the other thread, that’s not going to work.

Or are you trying on a Linux desktop computer now?

Edit: you install it by running that script on a Linux computer. (I tried it and it works.) It won’t work on a phone, though.