[Solved] Capacity Used

Hi i’ve got a problem.
When i try to import(model) or convert to j3o ,engine starts to work really slow and takes ages , while it uses only 20% of resources of my pc (even lesser for ram) .
Is there any way to fasten it up and use more resources ?
Some times it just freez and seems to never unfreez.
The size of model i try impor now is 10.000 KB
and got some error like " heap space "
I use Windows 10 .

i have 16gb ram or soo

“Resource usage” is not at all a good guide for how much work a program is doing, and very, very few programs can use 100% of a multicore machine. 20% probably means it was running one core at 100%, and less RAM use is better than more (if you run out of RAM and the OS starts page swapping your entire machine will become terribly slow and may start locking up for seconds at a time). The only way to make code use more than one core is to make it multithreaded, and more specifically to use a concurrent algorithm. In most cases this is difficult, and in many cases impossible. At any rate, changing this would require substantial code changes. So in short, this behavior sounds like a bug, but if it isn’t you’ll just have to wait it out and let it take its course.

Try using jMonkeyBuilder

Yeah ok ,but what should i do with a model that cant be leaded and gives error " Heap space " ?
Each time it just fail’s to load 10.000 KB model,and i need it ,its my map …

If you are using the SDK see https://wiki.jmonkeyengine.org/sdk/increasing_heap_memory.html

  1. Most importers can only use one core
  2. 10MiB is a HUGE Model so it takes some time because every triangle has to be processed, sometimes triangulated, tangents generated etc
  3. This code is designed to just work someway, not optimized for speed as you have time when importing models usually.

But really have a look at your model, it seems to be too huge (which isn’t awesome, also concerning load time later on (you would want to load multiple j3os at a time and also on demand depending on where you are on the map))

If your models aren’t massive: have you tried restarting the SDK and converting the model to .j3o again? I think I ran into this problem in the past and all I needed to do was restart.

I cant some thing i cant import to . It simply not creates a model in Models of project

Explain your workflow please. You can’t import what? I know it’s a mesh, but in what format? obj? gtlf? blend? The recommended method is GTLF.

If you are running out of memory it means that the maximum amount of allocated memory has been exceeded, but you would need to provide the exact error as displayed to you in order for us to understand what exactly happened. I presume you just need to increase the memory allocated by default; in which case the documentation provided explains how to do so:


In respect to the time it takes, there’s not a lot anybody can do except increase your processor speed. A mesh that huge will just take time. There’s not a lot anybody can do about that except yourself. Blender (again i presume) is a hugely sophisticated tool. Again - if you provide more information maybe someone can assist you further on that.

It worked Thank you :slight_smile: problem solved :smiley: