[SOLVED] ChaseCam movements not working properly


I’ve implemented ChaseCam to my player and one issue I can’t figure out how to solve is that whenever I move my player, be it any direction, the ChaseCam will “glide” closer and closer to that direciton. How do I disable this “gliding”? I’ve tried setting trailing to off but that only eliminates the glide movement and the ChaseCam will immediately zoom in way too far towards the direction I’m moving my player. Is there a way to have it follow my player without offsetting on movement? Thanks :slight_smile:

EDIT: Here are some screenshots to better show my problem

  1. Normal view, no movement

  2. Moving forward (camera zooms in and goes through my model)

  3. Moving backwards (camera zooms back far away, opposite of previous picture)

I believe the method is something along the lines of setSmoothTrailing(false)

Or something like that.

Nope. I’ve already read the whole documentation and there doesn’t seem to be anything that deals with this…

It is absolutely setSmoothMotion(false);

Updated with screenshots to better explain my issue. setSmoothMotion(false) doesn’t help :frowning:

Are you sure that specific model is being followed by the chase cam?

Be sure to determine your minimum and maximum distances. Maybe set it to a fixed amount.

You may have some wacky trailing sensitivity or an odd model sizing as well.

Well the model sizing is indeed wacky, it’s set to scale down 0.005f. I will attempt to use a placeholder pre-scaled Blender model. And the chaseCam returns to its previous position once I stop moving.

No change. Still same difference. Here is my code for chaseCam modifications:

    //Setting up chase camera
    chaseCam = new ChaseCamera(this.getCamera(), playerSpatial, inputManager);

I tried deleting the distances, I tried enabling trailing, smooth motion and reducing its sensitivity to 0. No difference.

Solved it. I was moving the spatial along with the player object. For some reason disabling the spatial movement solves it. (Only the char control moves now).