[SOLVED]"convert to JME3 binary" is not an option


I’ve just started working with jMonkey, and am currently working through the tutorials.

However, I just got to the part where .j3o files are explained, and why this is neccesary. The following to-do list is given:

Open your JME3 Project in the jMonkeyEngine SDK.

  1. Right-click a .Blend, .OBJ, or .mesh.xml file in the Projects window, and choose “convert to JME3 binary.
  1. The .j3o file appears next to the .mesh.xml file and has the same name.
  2. Update all your loadModel() lines accordingly.

I wanted to try this out, and so I tried to convert the Ninja.mesh.xml file (project HelloAssetTutorial → Libraries → jme3-test-data → Models.Ninja → Ninja.mesh.xml). However, when I right-click this file, only a box appears to ‘Open javadoc’ (which is unclickable).

I checked the plug-ins, and OgreXML Tools is activated. Do I need to download something else or am I missing something?

Thanks in advance!!

Hello @BramIsABob, the model needs to be in your asset folder to convert it. Just copy and paste the needed files (.mesh, .material and the texture) to your assets folder.
I hope it’s clearer now.

Best regards

Hello @Domenic,

Yes, that worked, thank you very much!

I have one more question however: I converted the file, but it was converted from a mesh.xml file to a mesh.j3o file. The tutorial claims that it should only be a .j3o file.

Is this normal?

1 Like

Thats just a naming issue since the SDK might only exchange the extension (xml to j3o).
If you can open it (probably double click or right click open in scene composer), you can verify the conversation

Yes, this works! Thank you very much!