[Solved] Engine crashes with little to no error message when run in windowed mode

If I run the engine in windowed mode, the following happens:

I hit the run and the little window with the graphics settings show up. I hit the ‘continue’ button (without fullscreen selected) and this error shows up, along with a single window that looks like its from the swing era that says:

Failed to create display

This is the error in the netbeans console:

Mar 02, 2016 10:00:38 AM com.jme3.app.Application handleError
SEVERE: Failed to create display
	at com.jme3.app.Application.reshape(Application.java:526)
	at com.jme3.system.lwjgl.LwjglWindow$2.invoke(LwjglWindow.java:205)
	at org.lwjgl.glfw.GLFWWindowSizeCallback.callback(GLFWWindowSizeCallback.java:45)
	at org.lwjgl.system.JNI.invokePV(Native Method)
	at org.lwjgl.glfw.GLFW.glfwShowWindow(GLFW.java:1692)
	at com.jme3.system.lwjgl.LwjglWindow.createContext(LwjglWindow.java:246)
	at com.jme3.system.lwjgl.LwjglWindow.initInThread(LwjglWindow.java:327)
	at com.jme3.system.lwjgl.LwjglWindow.run(LwjglWindow.java:446)
	at java.lang.Thread.run(Thread.java:745)

Mar 02, 2016 10:00:38 AM com.jme3.system.lwjgl.LwjglWindow run
SEVERE: Display initialization failed. Cannot continue.

I’ve just started tinkering around with the jmonkeyengine, and upon reading that the SDK is no longer supported, I just opened my regular netbeans ide and started a maven project. This is the dependencies section of my pom.xml:


And this is my only source file (imports omitted):

public class HelloJME3 extends SimpleApplication {
    public static void main(String[] args) {
        HelloJME3 app = new HelloJME3();

    public void simpleInitApp() {
//        Box b = new Box(1, 1, 1);
//        Geometry geom = new Geometry("Box", b);
//        Material mat = new Material(assetManager, "Common/MatDefs/Misc/Unshaded.j3md");
//        mat.setColor("Color", ColorRGBA.Blue);
//        geom.setMaterial(mat);
//        rootNode.attachChild(geom);

At first I thought maybe there was something wrong with the code. Maybe the assetManager wasn’t working, so I commented it out, but it still crashes.

I did a bit of reading around the web on this issue with jmonkeyengine (I am not the first to have it), but I notice with everyone else at least they get a message, something about the assets.jar being a directory. I’m not even getting that error message.

I also created the assets folder in my project’s root directory, but that has not seemed to change anything.

Sorry if this question has already been answered somewhere in the past. From what I’ve searched, those who did get this error seemed to get more info to go off of, or the error was part of a larger issue, such has their graphics card not having the drivers installed or not supporting the right version of OpenGL (my graphics card drivers are installed, and supports OpenGL 4).

If I run the engine in fullscreen mode, it works fine.

I hope I have provided enough info to help you guys help me out.

Thanks in advance!

Nevermind, I have solved this issue. I would delete this thread, but just in case anyone else runs into the same issue, they can find the same resolution I did.

It turns out lwjgl3 doesn’t seem to be quite ready yet. Changing my maven dependency from jme3-lwjgl3 to jme3-lwjgl fixed everything.